Opened 12 years ago

Closed 11 years ago

#4733 closed defect (duplicate)

threads using QRegExp have to use QThread instead of pthread

Reported by: Janne Grunau Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Quoting http://doc.trolltech.com/3.3/qregexp.html#details

In case of multi-threaded programming, note that QRegExp depends on QThreadStorage internally. For that reason, QRegExp should only be used with threads started with QThread, i.e. not with threads started with platform-specific APIs.

Attachments (1)

eitcrash.diff (7.3 KB) - added by Janne Grunau 11 years ago.
original patch converting most of the threads to QThread from David

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by Janne Grunau

(In [16191]) Convert EITScanner pthread from pthread to QThread

From: David <david at unsolicited point net> Fixes a segfault in the EITFixup QRegExps. QRegExp depends on QThreadStorage which can only be used in threads created by QThread.

I'm just converting the EITScanner thread due to the near release date. Other threads using QRegExp should be converted too or maybe not. I have not seen the same warning in the qt 4.3 docs. Refs #4695, Refs #4733

comment:2 Changed 12 years ago by Janne Grunau

(In [16274]) Merges [16191] from trunk: Convert EITScanner pthread from pthread to QThread

From: David <david at unsolicited point net> Fixes a segfault in the EITFixup QRegExps. QRegExp depends on QThreadStorage which can only be used in threads created by QThread.

I'm just converting the EITScanner thread due to the near release date. Other threads using QRegExp should be converted too or maybe not. I have not seen the same warning in the qt 4.3 docs. Refs #4695, Refs #4733

Changed 11 years ago by Janne Grunau

Attachment: eitcrash.diff added

original patch converting most of the threads to QThread from David

comment:3 Changed 11 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #5501

Note: See TracTickets for help on using tickets.