Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4739 closed defect (fixed)

Myth can't play properly IPTV UDP/Multicast stream

Reported by: jyavenard@… Owned by: Janne Grunau
Priority: major Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using 0.20.2, Mythtv will play a UDP/Multicast stream perfectly. However, since upgrading to 0.21 trunk, the video pauses every few seconds, the sound is not in sync with the video etc.

A recording made by mythtv however, will play properly in VLC letting me believe that the issue isn't with the received stream but the media player.

I have posted a 38MB recording showing the problem. When played in MythTV trunk, it will exhibit the problem. Using 0.20.2 it will play perfectly.

The file is located at http://avenard.org/iptv/tv5_vlc.mpg

Change History (6)

comment:1 Changed 12 years ago by jyavenard@…

Ooops

Sorry I posted the wrong link: the recording is: http://avenard.org/iptv/tv5_myth.mpg

the http://avenard.org/iptv/tv5_vlc.mpg is a stream capture made using VLC ; it doesn't play in mythtv properly, this one has a green shade over 3/4 of the screen and the subtitles are shown again at the top of the screen in a extremely large font.

comment:2 Changed 12 years ago by stuartm

Does the VLC capture play with ffplay, mplayer or xine?

comment:3 Changed 12 years ago by jyavenard@…

mplayer: sound only ffmplay: sound only vlc : ok xine: ok

comment:4 Changed 12 years ago by Janne Grunau

Milestone: unknown0.21
Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

there is something strange happening. the dts is sometimes around -232 which looks like we are using somewhere 32bit arithmetik on the 64bit dts.

I'll apply a workaround for this.

comment:5 Changed 12 years ago by Janne Grunau

Resolution: fixed
Status: assignedclosed

(In [16459]) workaround negative dts needed for some h264 streams

Fixes #4739

comment:6 Changed 12 years ago by Janne Grunau

(In [16460]) Merges revision [16459] from trunk: workaround negative dts needed for some h264 streams

Fixes #4739

Note: See TracTickets for help on using tickets.