Opened 14 years ago

Closed 14 years ago

#493 closed defect (fixed)

Crash on number press with SmartChannelChange

Reported by: mythtv@… Owned by: danielk
Priority: critical Milestone: 0.19
Component: mythtv Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

If you enable SmartChannelChange? and play a recording, mythfrontend crashes on a number press.

The issue with SmartChannelChange? enabled, a number press causes a call to ChannelCommit?(), which apparently causes problems. I have not traced where the eventual crash takes place, but presume it's a cause of querying or setting the channel when not in live TV.

Patch is simple and follows.

It may have implications if you are watching a recording that was still being recorded. I've noticed that I was somehow able to change the channel in this mode. I do not view this as a feature and have not tried to reproduce the behavior predictably. I suspect that this is not intended behavior anyway.

Attachments (1)

channel.patch (584 bytes) - added by mythtv@… 14 years ago.
channelcrash.patch

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by mythtv@…

Attachment: channel.patch added

channelcrash.patch

comment:1 Changed 14 years ago by mythtv@…

Belt and suspenders fix.

  1. Do not call ChannelCommit?() from ChannelKey?() unless StateIsLiveTV().
  1. If !StateIsLiveTV(), then ChannelCommit?() calls ChannelClear?() and returns without going further.

comment:2 Changed 14 years ago by anonymous

Milestone: 0.19

comment:3 Changed 14 years ago by danielk

Milestone: 0.19
Owner: changed from Isaac Richards to danielk

comment:4 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7556]) Fixes #493.

Note: See TracTickets for help on using tickets.