Opened 12 years ago

Closed 10 years ago

#4946 closed defect (invalid)

Segfault in DVDRingBuffer

Reported by: david.morris@… Owned by: skamithi
Priority: minor Milestone: 0.22
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Ticked moved upstream from Ubuntu: https://bugs.edge.launchpad.net/ubuntu/+source/mythtv/+bug/197880 Full details found there as reported from apport

ProblemType?: Crash Architecture: i386 Date: Sun Mar 2 20:32:39 2008 DistroRelease?: Ubuntu 8.04 ExecutablePath?: /usr/bin/mythfrontend.real NonfreeKernelModules?: nvidia Package: mythtv-frontend 0.21.0~fixes16259-0ubuntu1 PackageArchitecture?: i386 ProcCmdline?: /usr/bin/mythfrontend.real --logfile /tmp/mythfrontend.6737.log ProcEnviron?:

PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games LANG=en_US.UTF-8 SHELL=/bin/bash

Signal: 11 SourcePackage?: mythtv StacktraceTop?:

?? () from /usr/lib/libmythtv-0.21.so.0 ?? () ?? () stdin () from /lib/tls/i686/cmov/libc.so.6 ?? () from /usr/lib/libmythtv-0.21.so.0

Title: mythfrontend.real crashed with SIGSEGV in stdin() Uname: Linux 2.6.24-10-generic i686 UserGroups?: adm admin audio cdrom dialout floppy lpadmin mythtv netdev plugdev powerdev sambashare scanner video

StacktraceTop:process_command (vm=0x921bff0, link_values= vm_start (vm=0x921bff0) at vm.c:290 dvdnav_part_play (this=0x82fe350, title=0, part=1) at navigation.c:158 dvdnav_title_play (this=0x0, title=0) at navigation.c:139 DVDRingBufferPriv::OpenFile? (this=0x95b2398, filename=@0xac19c690) at DVDRingBuffer.cpp:167

Change History (6)

comment:1 Changed 12 years ago by Isaac Richards

Status: newinfoneeded_new

Try with the 0.21 release.

comment:2 Changed 11 years ago by stuartm

Milestone: unknown0.21.1
Status: infoneeded_newnew

We might want to check the validity of the dvdnav pointer, but the underlying problem would probably be libdvdnav related.

comment:3 Changed 11 years ago by stuartm

Owner: changed from Isaac Richards to skamithi
Status: newassigned

comment:4 Changed 11 years ago by stuartm

Summary: mythfrontend.real crashed with SIGSEGV in stdin()Segfault in DVDRingBuffer

comment:5 Changed 10 years ago by stuartm

Milestone: 0.21.10.22
Status: assignedinfoneeded

Can you reproduce with trunk? I'm assuming this was fixed a while back since the ticket is pretty old and there have been no further reports.

comment:6 Changed 10 years ago by robertm

Resolution: invalid
Status: infoneededclosed

Information not provided within five weeks, closing. Please open a new ticket against trunk or .22 upon its release.

Note: See TracTickets for help on using tickets.