Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5017 closed defect (invalid)

mythfrontend crash with latest svn rev 16745

Reported by: Benoit LORAND <benoit.lorand@…> Owned by: Isaac Richards
Priority: blocker Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

when i launch mythfrontend it load theme and crash. See log attached.

I have deleted pluguin (in /opt/mythtv/lib/mythtv/plugins) that wouldn't load as it said in log attached but nothing do.

Attachments (1)

mythfrontend.log.tar.bz2 (6.5 KB) - added by Benoit LORAND <benoit.lorand@…> 12 years ago.
log

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Benoit LORAND <benoit.lorand@…>

Attachment: mythfrontend.log.tar.bz2 added

log

comment:1 Changed 12 years ago by anonymous

rev 16955: Mine also dies with a seg fault:

2008-04-05 18:38:07.951 New DB connection, total: 2
2008-04-05 18:38:07.952 Connected to database 'mythconverg' at host: localhost
2008-04-05 18:38:07.956 mythfrontend version: 0.22.20080320-2 www.mythtv.org
2008-04-05 18:38:07.957 Enabled verbose msgs:  important general
2008-04-05 18:38:08.139 The theme (oldosd) is missing a themeinfo.xml file
2008-04-05 18:38:08.315 The theme (oldosd) is missing a themeinfo.xml file
2008-04-05 18:38:08.574 Primary screen: 0.
2008-04-05 18:38:08.575 Using screen 0, 720x576 at 0,0
2008-04-05 18:38:08.578 Switching to square mode (Retro)
2008-04-05 18:38:08.591 Using the Qt painter
2008-04-05 18:38:08.593 lirc init success using configuration file: /home/mythtv/.mythtv/lircrc
2008-04-05 18:38:08.622 MC::NormalizeFontSize() called, but no window
2008-04-05 18:38:09.478 Loading from: /usr/local/share/mythtv/themes/Retro/base.xml
2008-04-05 18:38:09.563 Loading from: /usr/local/share/mythtv/themes/default/base.xml
2008-04-05 18:38:09.713 Registering Internal as a media playback plugin.

comment:2 Changed 12 years ago by stuartm

Resolution: invalid
Status: newclosed

We need a backtrace, but as stated on the -dev list, this is caused by a bad plugin (probably mythphone) you need to delete this plugin or rebuild ensuring that it's using Qt4.

comment:3 Changed 12 years ago by anonymous

ah - deleting old files did the trick: http://svn.mythtv.org/trac/ticket/5137#comment:6

Note: See TracTickets for help on using tickets.