Opened 14 years ago

Closed 14 years ago

#510 closed defect (duplicate)

Compile error in MythMusic with latest SVN

Reported by: kkuphal Owned by: Isaac Richards
Priority: critical Milestone: unknown
Component: mythmusic Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

I get this error when compiling MythMusic on my remote frontend with the latest SVN. CPU is a Celeron 2.something Ghz.

ccache gcc -c -pipe -march=pentium4 -Wall -W -g -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"/usr\" -DMMX -Di386 -DUSING_DBOX2 -D_FILE_OFFSET_BITS=64 -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_NO_DEBUG -I/usr/lib/qt-3.3/mkspecs/default -I. -I/usr/include -I/usr/kde/3.3/include -I/usr/include -I/usr/X11R6/include -I/usr/include/cdda -I/usr/lib/qt-3.3/include -I/usr/X11R6/include -o zoom_filter_xmmx.o goom/zoom_filter_xmmx.c
{standard input}: Assembler messages:
{standard input}:129: Error: suffix or operands invalid for `movq'
{standard input}:130: Error: suffix or operands invalid for `movq'
make[2]: *** [zoom_filter_xmmx.o] Error 1
make[2]: Leaving directory `/root/mythtv-svn/mythplugins/mythmusic/mythmusic'
make[1]: *** [sub-mythmusic] Error 2
make[1]: Leaving directory `/root/mythtv-svn/mythplugins/mythmusic'
make: *** [sub-mythmusic] Error 2

This compiled fine with revision [7482] which was the last one I compiled.

Change History (1)

comment:1 Changed 14 years ago by danielk

Resolution: duplicate
Status: newclosed

Appears to be a duplicate of #306.

gcc probably ran out of registers.

Its register allocation after version 2.95 or so hasn't been very good.

Note: See TracTickets for help on using tickets.