Opened 14 years ago

Closed 14 years ago

#547 closed defect (fixed)

rev 7639 - videosource.cpp doesn't compile

Reported by: hansi.urpils@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi! After running "svn up" on my Sarge box as well as on my Gentoo box, libs/libmythtv/videosource.cpp doesn't compile anymore.

Here's the full error:

ccache distcc g++-3.4 -c -pipe -march=pentium3 -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -Wall -W -g `freetype-config --cflags` -D_REENTRANT -DPIC -fPIC  -DMMX -Di386 -DUSING_DBOX2 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_OPENGL_VSYNC -DUSING_XV -DUSING_XVMC -DUSING_FRONTEND -DUSING_V4L -DUSING_IVTV -DUSING_BACKEND -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_NO_DEBUG -I/usr/share/qt3/mkspecs/default -I. -I/usr/include -I/usr/X11R6/include -I../.. -I../libmyth -I.. -Idvbdev -Impeg -I../libavcodec -I../libavutil -I../libmythmpeg2 -I/usr/include/qt3 -I/usr/X11R6/include -I/usr/X11R6/include -o videosource.o videosource.cpp
distcc[19355] ERROR: compile /home/laga/.ccache/videosourc.tmp.styx.19349.ii on localhost failed
videosource.cpp: In member function `void CardInput::sourceFetch()':
videosource.cpp:1987: error: `myth_system' undeclared (first use this function)
videosource.cpp:1987: error: (Each undeclared identifier is reported only once for each function it appears in.)
videosource.cpp: At global scope:
videosource.cpp:2529: warning: unused parameter 'diseq_type'
make: *** [videosource.o] Error 1

It happens with

gcc version 3.4.4 20050314 (prerelease) (Debian 3.4.3-13)

and

gcc version 3.3.6 (Gentoo 3.3.6, ssp-3.3.6-1.0, pie-8.7.8)

This seems kind of odd to me, because videosource.cpp got changed five days ago and definitely worked for me ~24 hours ago.

I hope someone can fix that, if it can be reproduced on their systems.

Kinds regards, Michael Haas

Change History (1)

comment:1 Changed 14 years ago by paulh

Resolution: fixed
Status: newclosed

(In [7642]) Add the missing header to videosource.cpp

Fixes #547

Note: See TracTickets for help on using tickets.