Opened 11 years ago

Closed 11 years ago

#5594 closed defect (fixed)

starting mythfrontend for second screen gives black-video-screen

Reported by: Markus Schulz <msc@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Starting mythfrontend with: # mythfrontend -display :0.1 _from_ display 0.0 gives the gui but only black video screen. starting with: # DISPLAY=:0.1 mythfrontend -display :0.1 works. Looks like the parameter -display will not be used for the xv-screen.

$ mythfrontend --version Please include all output in bug reports. MythTV Version : 18010M MythTV Branch : trunk Library API : 0.22.20080801-2 Network Protocol : 40 QT Version : 4.4.0 Options compiled in:

linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

Change History (5)

comment:1 Changed 11 years ago by Nigel

I haven't managed to reproduce this - my dual head test machine currently crashes X when trying to display Xv video.
Markus, I'm guessing that MythXOpenDisplay() isn't doing the right thing. Any chance of applying this patch:

Index: libs/libmythui/util-x11.cpp
===================================================================
--- libs/libmythui/util-x11.cpp (revision 18270)
+++ libs/libmythui/util-x11.cpp (working copy)
@@ -69,8 +69,12 @@
     Display *disp = XOpenDisplay(dispCStr);
     X11U;
 
-    if (!disp)
-        VERBOSE(VB_IMPORTANT, "MythXOpenDisplay() failed");
+    QString LOC = "MythXOpenDisplay() of '" + dispStr + "' ";
+ 
+    if (disp)
+        VERBOSE(VB_GENERAL+VB_EXTRA, LOC + "succeeded");
+    else 
+        VERBOSE(VB_IMPORTANT, LOC + "failed");
 
     return disp;
 }

and providing mythfrontend -v playback,extra | egrep 'X|screen' output? (both runs, unless the output is identical)

comment:2 Changed 11 years ago by Nigel

(In [18319]) The last of Daniel's Qt3->Qt4 in this file. See #5594. I am unable to test the CheckDeviceNotifications?() changes, because by udev setup only sends "mount/umount" notifications, not "add/remove" ones. The code is nearly identical to that in CheckMountable?(), so it should be good. (hint, someone could create a CheckRemovable?() for both of these to call)

comment:3 Changed 11 years ago by Nigel

Damn. That should have been #5596, not #5594

comment:4 Changed 11 years ago by Markus Schulz <msc@…>

can be closed, error was resolved in a version between 18198 <> 18296.

comment:5 Changed 11 years ago by stuartm

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.