Opened 11 years ago

Closed 11 years ago

#5644 closed defect (worksforme)

Mythvideo scans entire file space instead of just the specified subdir

Reported by: henrik.sorensen@… Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythvideo Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Watch Videos is taking a lot of time switching to the video browser. A bt from gdb showed a lot of nested scan_dir() calls. So I added a simple 'cout << "Scanning " << start_path << "...\n";' to the top of scan_dir().

The output shows it scanning the subtree of /home/cbaoth/Videos, which is the configured videostartupdir.. then it starts on the root file system for some odd reason.

Scanning /home/cbaoth/Videos/Top Gear/Season? 11... Scanning /home/cbaoth/Videos/Torchwood... Scanning /... Scanning /bin... Scanning /boot... Scanning /boot/grub...

Mythvideo settings: VideoStartupDir? is '/home/cbaoth/Videos' Default view: listings Show unknown file types is checked Video Browser|Gallery|List browses is checked

Using mythtv and plugins trunk rev 18198

(Had the similar issue with 0.21 release version where it at least scanned my entire homedir, but it was fixed somewhere along in fixes)

Change History (3)

comment:1 Changed 11 years ago by paulh

Component: mythtvmythvideo
Owner: changed from Isaac Richards to Anduin Withers
Version: unknownhead

comment:2 Changed 11 years ago by Anduin Withers

Status: newinfoneeded_new

I’ll need more information. The old bug was caused by not checking what the media monitor returned. If this is similar, output only in scan_dir() is insufficient. Put some unique output in ScanVideoDirectory?() as well so it is possible to differentiate between some directory recursion problem (there are some, symlink loops being the worst I know of) and directories you don’t expect, being scanned intentionally (perhaps).

comment:3 Changed 11 years ago by Dibblah

Resolution: worksforme
Status: infoneeded_newclosed

No response in 3 months and this code has changed recently. Closing.

Note: See TracTickets for help on using tickets.