Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 6 years ago

Closed 6 years ago

#5711 closed defect (invalid)

mythtv cannot open cx88_blackbird video device

Reported by: lfarkas@… Owned by: ijr
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21
Severity: high Keywords:
Cc: Ticket locked: no

Description

I've a Leadtek PVR2000 tv card.
mythtv cannot open the /dev/v4l/video1 file. So I cannot watch LiveTV or record anything.

When I log in as mythtv, and try to open the file, with the

cat /dev/v4l/video1 > something.mpg

command, it works without problems.

Attachments (1)

mythbackend.log (1.5 KB) - added by lfarkas@… 6 years ago.
last 25 lines of mythbackend.log

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by lfarkas@…

last 25 lines of mythbackend.log

comment:1 Changed 6 years ago by lfarkas@…

The problem is that my device cannot be opened twice. For example:

cat /dev/v4l/video1 > something1.mpg

works, but

cat /dev/v4l/video1 > something2.mpg

gives

error: Device or resource busy

If I patch the the libmythtv/mpegrecorder.cpp file to

close(chanfd)

before the command

open(readfd ...

then the device can be opened, but the channel cannot be set in LiveTV.

comment:2 Changed 6 years ago by danielk

  • Resolution set to invalid
  • Status changed from new to closed

V4L devices that can only be opened once are not supported in MythTV.

Closing, feature request without a patch.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.