Modify

Opened 9 years ago

Closed 7 years ago

#5949 closed defect (fixed)

Cannot tune some DVB-Tchannels

Reported by: g.carabetta@… Owned by: stuarta
Priority: minor Milestone: 0.24
Component: MythTV - Channel Scanner Version: head
Severity: medium Keywords:
Cc: stuarta Ticket locked: no

Description

After performed a good channel scan, it's impossible to see a lot of dvb-t channels. Only few of it works. Usually the screen goes black, I cannot try to change channel or to see the menu. I can just wait that the frontend exit with an error. Other times I see the channel browser, but cannot change channel: the screen rest black.

I compared channels info (from mysql "channel" and "dtv_multiplex" tables) with succesfully working channels from Kaffeine, and the data are the same.

System is AMD64 based, the card is Hauppauge Nova T-500, the Ubuntu is updated.

Attached the mythtv frontend and backend logs.

Attachments (6)

logs.tgz (11.9 KB) - added by g.carabetta@… 9 years ago.
frontend/backend logs
logs1.tgz (25.5 KB) - added by anonymous 9 years ago.
logs.2.tgz (83.4 KB) - added by g.carabetta@… 9 years ago.
logs.3.tgz (23.8 KB) - added by g.carabetta@… 9 years ago.
logs.4.tgz (139.5 KB) - added by g.carabetta@… 8 years ago.
logs.5.tgz (122.8 KB) - added by g.carabetta@… 8 years ago.

Download all attachments as: .zip

Change History (32)

Changed 9 years ago by g.carabetta@…

frontend/backend logs

comment:1 Changed 9 years ago by Dibblah

  • Component changed from mythtv to channelscan
  • Owner changed from ijr to danielk
  • Status changed from new to assigned

comment:2 Changed 9 years ago by Dibblah

  • Owner danielk deleted
  • Status changed from assigned to new

comment:3 follow-up: Changed 9 years ago by Dibblah

  • Status changed from new to infoneeded_new

Your log appears to be inconsistent.

You mention DVB, but that log seems to be from a hardware encoding card?

Can you please make sure that you have selected a DVB device in mythtv-setup?

comment:4 Changed 9 years ago by anonymous

First of all, I have 2 card, analog and DVB-T (Hauppauge PVR-500 & Hauppauge Nova T-500). PVR is configured as "MPEG-2 encoder card", the interesting one is configured as "DVB DTV capture card (v3.x)".

Frontend starts with analog card/channel, after that I switch manually to DVB-T.

I removed the Mythbuntu version, and moved to the .21-fixes but the problem is the same.

Attached are new logs, from new version, with improved log level.

Changed 9 years ago by anonymous

comment:5 in reply to: ↑ 3 Changed 9 years ago by g.carabetta@…

Yes, It's a DVB DTV capture card

Replying to Dibblah:

Your log appears to be inconsistent.

You mention DVB, but that log seems to be from a hardware encoding card?

Can you please make sure that you have selected a DVB device in mythtv-setup?

comment:6 Changed 9 years ago by Dibblah

In which case, something is wrong with your configuration. Is it possible for you to start again from a blank database?

comment:7 Changed 9 years ago by g.carabetta@…

Yes I can. I'd like to follow exact instructions.

Just to info, I tested channel data from channel/dtv_multiplex tables: using it in Kaffeine, works perfectly.

My version is:

oscar@oscar-desktop:~$ mythfrontend --version Please include all output in bug reports. MythTV Version : 19215 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_backend using_dbox2 using_dvb using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live

comment:8 Changed 9 years ago by stuarta

  • Milestone changed from unknown to 0.22
  • Version changed from unknown to 0.21-fixes

It looks like the channel you are trying to tune to isn't a proper video channel as there isn't a video & audio stream defined.

2008-12-09 20:50:49.129 PMT in input stream 2008-12-09 20:50:49.148 Program Map Table ver(0) pid(0x4b1) pnum(201) len(25)

Stream #0 pid(0xc9) type(unknown 0x90)

Stream Identifier Descriptor (0x52) length(1) Data Broadcast Identifier Descriptor (0x66) length(2)

There's not enough there to be able to record anything.

comment:9 Changed 9 years ago by g.carabetta@…

How I can send data to you for a futher investigation?

comment:10 Changed 9 years ago by stuarta

  • Cc stuarta added
  • Status changed from infoneeded_new to new

I'd assign this to myself, but i can't find the owner field. Suspect it's due to the ticket being infoneeded_new

comment:11 Changed 9 years ago by stuarta

  • Owner set to stuarta
  • Status changed from new to assigned

comment:12 Changed 9 years ago by stuarta

  • Status changed from assigned to infoneeded

comment:13 Changed 9 years ago by g.carabetta@…

I did a procedure to replicate the error and produce all needed logs.

Ubuntu 8.10 Windows-like setup: quink-and-dirty next-next-next... Updated all

sudo apt-get install phpmyadmin (just for test & db dump)

sudo apt-get install libttf-dev

sudo apt-get install libmp3lame-dev

sudo apt-get install libqt4-dev

sudo apt-get install autoconf automake

sudo apt-get install build-essential

sudo apt-get install libqt3-compat-headers libqt3-headers libqt3-mt libqt3-mt-dev libqt3-mt-mysql

sudo apt-get install libxv-dev

sudo apt-get install libxxf86vm-dev

sudo apt-get install mysql-client mysql-server

sudo apt-get install subversion

svn co http://svn.mythtv.org/svn/branches/release-0-21-fixes/

cd release-0-21-fixes/mythtv

./configure

make

su

make install

exit

cd database mysql -u root --password=dbroot_passwd < mc.sql

mythtv-setup --verbose siparser,channel,record | tee setup.log

In setup:

  • GENERAL 1° screen: PAL - None - Italy - Auto 2° next 3° next 4° next 5° next 6° next 7° next 8° finish
  • CAPTURE CARD New 1° DVB DTV capture card (v3.x)
    • other field on default and finish

VIDEO SOURCE New 1° Terrestrial - EIT only - italy finish

INPUT CONNECTIONS select first (unique) 1° name - video source -> Scan for channels

Country: german (what is it ???) next (scanning) finish - next - finish

STORAGE DIRECTORY Add a Default directory

exit

mythbackend --verbose siparser,channel,record -l mythbackend.log &

mythfrontend --verbose siparser,channel,record -l mythfrontend.log

Attached are all logs generated. Just in this run, I experienced a crash at the end of channel scanning, so there are more setup.log.

Changed 9 years ago by g.carabetta@…

comment:14 Changed 9 years ago by Dibblah

  • Status changed from infoneeded to assigned

comment:15 Changed 9 years ago by stuarta

  • Status changed from assigned to infoneeded

Can you test this against current svn please? The channel scanner has been rewritten.

Thanks Stuart

comment:16 Changed 9 years ago by g.carabetta@…

I strictly followed the procedure previously explained, but with Ubuntu 9.04 (same AMD64 as before).

The version is:

oscar@oscar-desktop:~$ mythbackend --version Please include all output in bug reports. MythTV Version : 20511 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_backend using_dbox2 using_dvb using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live

The result is no channels found, and tables dtv_multiplex and channels are empty.

Looking in log files I see that it tryed correct frequency (for example 698000000Hz) but with no luck.

I've also noticed that all 3 times the application disappeared (crashed?). 1st time when scanning was finished; 2nd time when I pressed "cancel" button while scanning; 3rd time around 50% of scanning.

Logs attached.

Changed 9 years ago by g.carabetta@…

comment:17 Changed 9 years ago by stuarta

Please test with head, the channel scanner has been rewritten

Stuart

comment:18 Changed 9 years ago by stuartm

  • Resolution set to invalid
  • Status changed from infoneeded to closed

No response to request after 30 days, closing.

comment:19 follow-up: Changed 8 years ago by g.carabetta@…

I made there new test with the version obtained with:

svn co http://svn.mythtv.org/svn/trunk/

I made all as previously described. It's all more stable (never crashed). In "scanning channel" options page, I left the "Australia" default. But I got just 6 channels on a single multiplex frequence.

After inserted such channel, I tryed to rescan using "Great Britain" and it found about 150 channel (conflicting and not).

They seems to be correct. Can you verify the logs? It's correct to use the GB country?

Thanks

Changed 8 years ago by g.carabetta@…

comment:20 in reply to: ↑ 19 Changed 8 years ago by janne

  • Resolution invalid deleted
  • Status changed from closed to new

Replying to g.carabetta@abi.it:

After inserted such channel, I tryed to rescan using "Great Britain" and it found about 150 channel (conflicting and not).

They seems to be correct. Can you verify the logs? It's correct to use the GB country?

judging from the logs and your email address GB is obviously wrong. But wrong doesn't mean that it doesn't work. Tuning parameters for most european DVB-T channels are similar so it will usually work. I don't know know why it finds so much duplicate channels though. please attach a log from

mythtv-setup -v channel,channelscan,siparser

Does your original problem still exist with trunk?

comment:21 Changed 8 years ago by janne

  • Status changed from new to infoneeded_new
  • Version changed from 0.21-fixes to head

Changed 8 years ago by g.carabetta@…

comment:22 Changed 8 years ago by g.carabetta@…

The original problem doesn't exixst anymore: it was "no channels at all", now there are "too much channels"! :)

Looking around the channels, via frontend, I got errors, of 2 types: "JumpToProgram?'s OpenFile? failed" and SegFault?. I added a comment in frontend log when SegFault?.

May be duplicate channel related?

Thanks

Giulio

PS: To make new test, I started with a drop database.

comment:23 Changed 8 years ago by stuartm

  • Component changed from channelscan to MythTV - Channel Scanner
  • Status changed from infoneeded_new to new

comment:24 Changed 8 years ago by stuarta

  • Milestone changed from 0.22 to 0.24

comment:25 Changed 8 years ago by robertm

  • Status changed from new to assigned

comment:26 Changed 7 years ago by robertm

  • Resolution set to fixed
  • Status changed from assigned to closed

Closing this as "probably fixed in .24," as well as the current state of the bug being so obfuscated by ticket spam that it's impossible to tell one way or another. If you will see issues upon the release of .24, please log a new ticket with new logs.

Add Comment

Modify Ticket

Action
as closed The owner will remain stuarta.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.