Opened 11 years ago

Closed 10 years ago

#5989 closed defect (fixed)

Dvd playback problem - PCM DVD unsupported sample depth

Reported by: wstewart@… Owned by: skamithi
Priority: major Milestone: 0.22
Component: MythTV - DVD Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by skamithi)

The Biography channel Barack Obama DVD does not play. The frontend log is flooded with error messages.

Attachments (5)

frontendlog.zip (1.3 KB) - added by wstewart@… 11 years ago.
frontend log; zipped cause trac wouldn't accept raw file
mythfrontend.zip (4.7 KB) - added by wstewart@… 11 years ago.
With -v playback
change_dvd_pcm_audio_type.diff (571 bytes) - added by skamithi 10 years ago.
change dvd audio type from pcm_dvd to pcm_s16BE if its startcode is a0..what it was before the latest ffmpeg resync
move_addaudiodata_from_IMPORTANT_TO_PLAYBACK.diff (1.6 KB) - added by skamithi 10 years ago.
logging of the addaudiodata error messages can really slow things esp in dvd menus. moving it to playback error class makes playback much smoother.
proper_fix_in_pcm.c.diff (409 bytes) - added by skamithi 10 years ago.
after reading ffmpeg alias, looks like code was changed to support LPCM. found what looks to be atypo int he code that is causing this problem. attached fix

Download all attachments as: .zip

Change History (21)

Changed 11 years ago by wstewart@…

Attachment: frontendlog.zip added

frontend log; zipped cause trac wouldn't accept raw file

Changed 11 years ago by wstewart@…

Attachment: mythfrontend.zip added

With -v playback

comment:1 Changed 11 years ago by wstewart@…

Checked playback with a different DVD, all is fine. Running trunk 19252. Have to return this DVD to the library, so I hope the logs are enough.

comment:2 Changed 11 years ago by skamithi

Description: modified (diff)
Status: newinfoneeded_new

error from wstewart's log is:

2008-12-07 19:25:49.828 [pcm_dvd @ 0xb6fefbd0]PCM DVD unsupported sample depth
2008-12-07 19:25:49.828 [pcm_dvd @ 0xb6fefbd0]invalid PCM packet

Assigning the case to janneg. I have a stripped dvd that produces the same error and will provide a link to the stripped dvd soon. Problem appears after latest ffmpeg resync.

comment:3 Changed 11 years ago by skamithi

Status: infoneeded_newnew
Summary: Dvd playback problem - Bio Barack ObamaDvd playback problem - PCM DVD unsupported sample depth

comment:4 Changed 11 years ago by Dibblah

Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

comment:5 Changed 11 years ago by skamithi

Chopped DVD can be found at http://38.114.169.249/pcm_dvd_failure_dvd.tar.bz2

When you start the dvd, select "DVD Menu" from the OSD, to get to the DVD Menu, then select "play movie". Problem is visible then.

This chopped dvd was provided to me by Otto Kolsi, a long time ago.

comment:6 Changed 11 years ago by skamithi

this issue may be related to a discussion on ffmpeg thread . no patch has been applied. will test the discussed patches and see which one works.

comment:7 Changed 11 years ago by skamithi

(In [20052]) Refs #5989. add PCM_DVD to codec_type_string. PCM_DVD codec been reported as PCM_S16E instead.

comment:8 Changed 11 years ago by skamithi

Owner: changed from Janne Grunau to skamithi

taking over this ticket. now that the codec_type is been reported properly. i see what the problem is.

comment:9 Changed 10 years ago by bhuffman@…

Any news on this? I'm still seeing this in trunk on certain DVDs.

comment:10 Changed 10 years ago by skamithi

the problem is that a new PCM format was introduced in ffmpeg, PCM_DVD. on some dvds, this PCM format is seen in the first dvd cell but no where else. mythtv is currently not able to switch to the PCM_S16E format that is used by the rest of the dvd, so incorrectly decodes PCM_S16E audio as PCM_DVD audio. It doesn't detect the change from pcm_dvd to pcm_s16e as a stream change, so doesn't close the codec and restart the codec using the pcm_s16e format.

The latest ffmpeg sync should help somewhat with this problem, on some dvds, as the pcm_dvd code in ffmpeg was fixed to better handle audio that should be using pcm_dvd format. and i was waiting for this to happen before i look further into a fix for this issue.

Right now i cannot look into this issue.

if someone wants to take a stab at this problem and wants some tips on where to start, email me and i can offer my 2c on the matter.

comment:11 Changed 10 years ago by skamithi

Milestone: unknown0.22
Priority: minormajor

This needs to be fixed before 0.22 is released. hopefully will get some time to fix this in sept if no one provides a fix before then.

comment:12 Changed 10 years ago by stuartm

Component: mythtvMythTV - DVD Playback

Changed 10 years ago by skamithi

change dvd audio type from pcm_dvd to pcm_s16BE if its startcode is a0..what it was before the latest ffmpeg resync

comment:13 Changed 10 years ago by skamithi

Severity: mediumhigh

bhuffman, and wstewart. please test the latest patch attached to this ticket. it fixed the problem on my test dvd. if it works for you i'll get it committed asap. still not sure why this change occurred in ffmpeg. Need to investigate..

Changed 10 years ago by skamithi

logging of the addaudiodata error messages can really slow things esp in dvd menus. moving it to playback error class makes playback much smoother.

comment:14 Changed 10 years ago by skamithi

Severity: highmedium

Changed 10 years ago by skamithi

Attachment: proper_fix_in_pcm.c.diff added

after reading ffmpeg alias, looks like code was changed to support LPCM. found what looks to be atypo int he code that is causing this problem. attached fix

comment:15 Changed 10 years ago by skamithi

(In [21891]) Refs #5989. Refs #4862. after ffmpeg resync added LPCM support, 16bit pcm audio in dvds fails everytime. found what looks to be a typo that resolves the issue. will send an email to ffmpeg alias to confirm.

comment:16 Changed 10 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [21901]) Closes #5989. move AddAudioData? error notification from IMPORTANT to PLAYBACK. makes dvd menu audio playback less jumpy during transitions.

Note: See TracTickets for help on using tickets.