Opened 11 years ago

Closed 11 years ago

#6113 closed defect (worksforme)

Mythtv tends to hang when exiting LiveTV

Reported by: Paul van Gerven <baloedebruinebeer@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

About 1 in 4 to 5 times, I have to wait 16 seconds before the menu appears after switching off live TV. On rare occasions, Mythfrontend doesn't recover at all.

This is what causes it (from the frontend output):

2009-01-11 10:02:07.885 RingBuf?(/media/mythtv/intrepid/1015_20090111100026.mpg) Error: Waited 16 seconds for data, aborting.

There is nothing in the backend log at the same time that indicates an error, but I do not know how to turn on verbose logging there.

The error was described a long time ago, and supposedly fixed (http://www.mail-archive.com/mythtv-commits@mythtv.org/msg05500.html) and I cannot find recent reports of it, yet the problem is very real for me.

Using Mythtv 0.21.0 from the repositories of Ubuntu Intrepid, completely up to date.

Attached is as much output as I could get from mythfrontend -v all from when I start the frontend, start watching TV for a few seconds, exit, get the freeze and exit the frontend alltogether. The error is at 10:02:07.885.

Attachments (2)

output_frontend (34.0 KB) - added by Paul van Gerven <baloedebruinebeer@…> 11 years ago.
verbose output of mythfrontend started in terminal
gdb.txt (5.3 KB) - added by baloedebruinebeer@… 11 years ago.
Starting LiveTV, exiting, experiencing a freeze, and exiting mythtv normally

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Paul van Gerven <baloedebruinebeer@…>

Attachment: output_frontend added

verbose output of mythfrontend started in terminal

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Can you please get a backtrace at the time where it is hanging?

Instructions here:

http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

comment:2 Changed 11 years ago by baloedebruinebeer@…

Apologies, I am new at this. What executable do I specify for gdb? /usr/bin/mythfrontend is a script.

multimedia@snotrochel:~$ gdb mythfrontend -x gdbcommands GNU gdb 6.8-debian Copyright (C) 2008 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Type "show copying" and "show warranty" for details. This GDB was configured as "i486-linux-gnu"... "/usr/bin/mythfrontend": not in executable format: File format not recognized /home/multimedia/gdbcommands:6: Error in sourced command file: No executable file specified. Use the "file" or "exec-file" command. (gdb) quit

comment:3 Changed 11 years ago by paulh

Could be something like mythfrontend.real

Changed 11 years ago by baloedebruinebeer@…

Attachment: gdb.txt added

Starting LiveTV, exiting, experiencing a freeze, and exiting mythtv normally

comment:4 Changed 11 years ago by Dibblah

Unfortunately, this backtrace is not usable, since you need to have debugging symbols available. You should be able to install a package which includes them for MythTV.

https://wiki.ubuntu.com/DebuggingProgramCrash for example.

comment:5 Changed 11 years ago by baloedebruinebeer@…

It appears such a package is not offered anymore (I can find one only for Dapper). I suppose I'll give compiling Mythtv myself a try.

comment:6 Changed 11 years ago by Dibblah

Resolution: worksforme
Status: infoneeded_newclosed

No response in 6 weeks.

Note: See TracTickets for help on using tickets.