Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6490 closed defect (invalid)

Page allocation failure prevents recording until backend restart

Reported by: mythtv@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - DVB/ATSC Version: 0.21-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

Using an ATSC USB tuner (the Pinnacle PCTV HD Pro stick, driver em28xx), on Ubuntu Intrepid x64 I get a regular 'page allocation failure' that prevents recording. The dmesg backtrace talks about dma allocation, usb, em28xx driver and dvb in that order (see attachment).

Symptoms: After the error, going to LiveTV will always show the banner, but 'Partial Lock' - never acquiring 'Lock' and never showing video. This prevents recordings from happening as well - they are entered in the list, but do not exist on disk and show up as 'File missing' when played.

To (temporarily) fix, one can:
stop the backend
unplug the tuner (USB)
replug the tuner
start the backend

After these steps, LiveTV works fine - but it will not stay fixed for long, the same error will reoccur. The error has gotten significantly more frequent recently; it used to be several days between each occurrence, but now I can't even record a single program.

I am unaware, nor do I know how to find out, whether this is a bug in the kernel, the driver, or MythTV. I'll be glad to do whatever is needed to pinpoint this down...

See attached for relevant DMesg output

Attachments (1)

dmesg-error.log (18.7 KB) - added by mythtv@… 11 years ago.
dmesg output - from plugging in adapter to error

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by mythtv@…

Attachment: dmesg-error.log added

dmesg output - from plugging in adapter to error

comment:1 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

This is a driver bug. It can probably be worked around by allocating more memory to the kernel, but should also be addressed in the driver.

comment:2 Changed 11 years ago by anonymous

Thanks. I'll look into the driver portion of it. Is this a common error?

Note: See TracTickets for help on using tickets.