Opened 10 years ago

Closed 10 years ago

#6570 closed defect (fixed)

MHEG issues with NZ freeview HD service

Reported by: Steven Ellis <steven@…> Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.22
Component: MythTV - General Version: 0.21-fixes
Severity: medium Keywords: mheg
Cc: Ticket locked: no

Description

The freeview HD service in New Zealand recently introduced a major update to their MHEG-5 based EPG to add support for STBs with PVR features. Since this update any attempt to start the MHEG-5 application will result in the frontend exiting.

There is a sample file at that can reproduce the problem.

Here is the backtrace and I will be attaching my debug output shortly.

#0  0x095d5b97 in ?? ()
#1  0xb6d416a7 in MHEngine::EventTriggered (this=0xa19feb18, pSource=0x966ed18, ev=EventIsAvailable, evData=@0xa05ff098) at Engine.cpp:429
#2  0xb6d3f07b in MHEngine::EventTriggered (this=0xa19feb18, pSource=0x966ed18, ev=EventIsAvailable) at Engine.h:90
#3  0xb6d59e7e in MHRoot::Preparation (this=0x966ed18, engine=0xa19feb18) at Root.cpp:58
#4  0xb6d4ed19 in MHIngredient::Preparation (this=0x966ed18, engine=0xa19feb18) at Ingredients.cpp:123
#5  0xb6d615d3 in MHIntegerVar::Preparation (this=0x966ed18, engine=0xa19feb18) at Variables.cpp:129
#6  0xb6d49090 in MHGroup::Preparation (this=0x966e650, engine=0xa19feb18) at Groups.cpp:151
#7  0xb6d59b80 in MHRoot::Activation (this=0x966e650, engine=0xa19feb18) at Root.cpp:68
#8  0xb6d48e8b in MHGroup::Activation (this=0x966e650, engine=0xa19feb18) at Groups.cpp:161
#9  0xb6d48fb3 in MHApplication::Activation (this=0x966e650, engine=0xa19feb18) at Groups.cpp:364
#10 0xb6d43641 in MHEngine::Launch (this=0xa19feb18, target=@0xa05ff25c, fIsSpawn=false) at Engine.cpp:226
#11 0xb6d4734f in MHLaunch::Perform (this=0x97702a8, engine=0xa19feb18) at Groups.cpp:584
#12 0xb6d41a7c in MHEngine::RunActions (this=0xa19feb18) at Engine.cpp:393
#13 0xb6d438f9 in MHEngine::RunAll (this=0xa19feb18) at Engine.cpp:99
#14 0xb7ab44ac in MHIContext::RunMHEGEngine (this=0xa937c918) at mhi.cpp:203
#15 0xb7ab4527 in MHIContext::StartMHEGEngine (param=0xa937c918) at mhi.cpp:172
#16 0xb5aa850f in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#17 0xb5901a0e in clone () from /lib/tls/i686/cmov/libc.so.6

Attachments (3)

gdb.txt (92.1 KB) - added by Steven Ellis <steven@…> 10 years ago.
GDB debug output
myth.log.gz (59.9 KB) - added by Steven Ellis <steven@…> 10 years ago.
Mythtv frontend output
launchfix.patch (551 bytes) - added by David Matthews <dm@…> 10 years ago.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by Steven Ellis <steven@…>

Attachment: gdb.txt added

GDB debug output

Changed 10 years ago by Steven Ellis <steven@…>

Attachment: myth.log.gz added

Mythtv frontend output

comment:1 Changed 10 years ago by Steven Ellis <steven@…>

Test environments

  • Ubuntu 9.04
  • Ubuntu 8.10

MythTV Builds

  • 0.21 fixes from Mythbuntu 8.10
  • 0.21 fixes from Mythbuntu 9.04
  • Jean-Yves VDPAU 0.21 backport builds

The problem is reproducible on all 0.21 builds, and I used Jean-Yves debug build to produce the gdb backtrace

  • 1:0.21.0+fixes-20550-openglvdpau-debug-0ubuntu2

GDB was run with the following gdbcommands file

handle SIGPIPE nostop noprint
handle SIG33 nostop noprint
set logging on
set pagination off
set breakpoint pending on
break qFatal
set args -l myth.log -v record,channel,siparser,mheg
run
thread apply all bt full
set logging off

comment:2 Changed 10 years ago by Steven Ellis <steven@…>

To reproduce problem download 25 Mb sample video and import as a recorded tv program.

On playback hit F12 to start the freeview NZ MHEG-5 EPG, and the frontend with crash.

Changed 10 years ago by David Matthews <dm@…>

Attachment: launchfix.patch added

comment:3 Changed 10 years ago by David Matthews <dm@…>

I've attached a simple patch that should fix this. The engine wasn't clearing actions from the queue on a Launch which I think it should be doing, at least according to the MHEG standard. The MHEG code in the sample you posted is rather odd in that the Link that calls Launch has actions after it which will now never be executed. It may be that the NZ MHEG profile defines something different in this case.

David

comment:4 Changed 10 years ago by Stuart Auchterlonie

Owner: changed from Isaac Richards to Stuart Auchterlonie
Status: newassigned

comment:5 Changed 10 years ago by Stuart Auchterlonie

Status: assignedinfoneeded

Steven,

any news on if the attached patch fixes the problem?

Stuart

comment:6 Changed 10 years ago by stuartm

(In [20910]) Possible fix for NZ MHEG related segfault from David Matthews. There was no confirmation of the fix from the submitter, but David states that this fix is required for spec compliance anyway. Refs #6570.

comment:7 Changed 10 years ago by stuartm

Milestone: 0.21.10.22
Resolution: invalid
Status: infoneededclosed

No response from the submitter in over 30 days, please re-open if the problem persists with trunk.

comment:8 Changed 10 years ago by steven@…

Sorry my previous post to confirm this fixed the issue appears to have gone missing.

Yes the patch resolved the fault.

comment:9 Changed 10 years ago by Stuart Auchterlonie

Resolution: invalid
Status: closednew

comment:10 Changed 10 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

Sorry for the noise, just getting the ticket resolution correct.

Note: See TracTickets for help on using tickets.