Opened 11 years ago

Closed 11 years ago

#6641 closed defect (duplicate)

MythFrontEnd can't play ISO9660 DVD

Reported by: gdisol <gdisol@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I debugged libdvdnav to understand the why we have a DVDopenFileUDF error with ISO9660 disks:

dvd_reader.c (part of libdvdnav library) executes DVDOpenImageFile where the variable dvd->isImageFile gets 1 that means True. After this all the access will be done understanding that your DVD must be a UDF filesystem compatible. If not (a IS09660 DVD) you will have the DVDOpenFileUDF errors.

What I can't understand is why Libdvdnav is not trying to get the ISO9660 access instead of UDF specially after the the O.S. mounted the DVD as a ISO9660 type and not UDF. The source code of Libdvdnav said that all block/char devices or files are being access using UDF ignoring IS0 ....

So, all in all the question is : Libdvdnave will have real supoort of ISO9660 ????? Thanks

Change History (1)

comment:1 Changed 11 years ago by Dibblah

Resolution: duplicate
Status: newclosed

Duplicate of #6621

Note: See TracTickets for help on using tickets.