Opened 11 years ago

Closed 10 years ago

#6707 closed defect (invalid)

Occasional series of recordings without audio

Reported by: josh@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have a MythTV system with three tuners: one PVR-350 and one two-tuner PVR-500. Occasionally, this system gets into a state where all recordings on a given tuner stop having sound. When this happens, mythbackend puts out error messages like this into the log file:

2009-07-09 21:00:32.086 AFD: Opened codec 0xa1b1d00, id(MPEG2VIDEO) type(Video) 2009-07-09 21:00:32.112 NVP: Disabling Audio, params(-1,-1,-1) 2009-07-09 21:00:32.115 NVP: Disabling Audio, params(0,-1,-1)

For lack of a better solution, I usually end up just rebooting the box to make the problem go away, and then deleting the bad recordings and telling them to re-record. However, I'd really like to see this problem stop.

josh@myth:~$ mythbackend --version Please include all output in bug reports. MythTV Version : exporté MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

Please let me know what other information I can provide to help get this problem resolved.

Attachments (2)

sample.nosound.mpg (256.0 KB) - added by josh@… 11 years ago.
Sample of a recording with no sound
sample.sound.mpg (256.0 KB) - added by josh@… 11 years ago.
Sample of a recording with sound

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by josh@…

Re-pasting those lines with wiki formatting to keep them from becoming a single paragraph:

2009-07-09 21:00:32.086 AFD: Opened codec 0xa1b1d00, id(MPEG2VIDEO) type(Video)
2009-07-09 21:00:32.112 NVP: Disabling Audio, params(-1,-1,-1)
2009-07-09 21:00:32.115 NVP: Disabling Audio, params(0,-1,-1)
josh@myth:~$ mythbackend --version
Please include all output in bug reports.
MythTV Version   : exporté
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

comment:2 Changed 11 years ago by danielk

Josh, when you play those files in another video player, mplayer, vlc, etc. do you have sound then? In that case we'll need a short sample of the file (15 sec, you can use top to lop it off).

comment:3 Changed 11 years ago by josh@…

No, I don't have sound when I play the files in mplayer either. As far as I can tell from the output of mplayer, the files don't have an audio stream at all.

I can get you a sample later today. What do you mean by "use top to lop it off" though?

Changed 11 years ago by josh@…

Attachment: sample.nosound.mpg added

Sample of a recording with no sound

Changed 11 years ago by josh@…

Attachment: sample.sound.mpg added

Sample of a recording with sound

comment:4 Changed 11 years ago by josh@…

I've attached a sample of a recording with no sound, and a sample of a recording *with* sound from later that evening after having rebooted the MythTV box.

I had to truncate both samples to 256kB to fit Trac's attachment size limit. If you need more of the files than that, please let me know and I can send them to you some other way.

Thanks for looking into this.

comment:5 Changed 11 years ago by josh

While this still represents an issue that ought to get fixed, I replaced the PVR-350 with a PVR-500 and I haven't had a problem since. Thus, I can no longer reproduce this problem.

comment:6 Changed 10 years ago by stuartm

Resolution: invalid
Status: newclosed

Suspect the original issue was driver related, but since the original reporter no longer has the hardware, the bug was opened against an old version and we've no additional reports I'm closing as invalid.

Note: See TracTickets for help on using tickets.