Opened 10 years ago

Closed 10 years ago

#6780 closed defect (fixed)

FE segfaults when watching DV video

Reported by: tapio.sami@… Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: MythTV - Video Playback Version: head
Severity: low Keywords:
Cc: tapio.sami@… Ticket locked: no

Description

Trying to watch DV video from camcorder (DCR-TRV310E PAL), ends up in mythfrontend crashing. Also the video size on the screen changes from all screen to ridiculously small little box of different sizes and location on the screen. But crash will come sooner or even sooner.

htpc:/home/mythtv# mythbackend --version Please include all output in bug reports. MythTV Version : 21049 MythTV Branch : trunk Library API : 0.22.20090727-1 Network Protocol : 45 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_backend using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (13)

gdb.txt (36.9 KB) - added by tapio.sami@… 10 years ago.
backtrace
gdb.2.txt (40.8 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
myth.log (48.3 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
gdb2.txt (38.5 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
myth2.log.bz2 (17.2 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
gdb3.txt (41.4 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
myth3.log (20.1 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
gdb4.txt (671 bytes) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
myth4.log (19.7 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
gdb5.txt (42.2 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
myth5.log (20.2 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
gdb6.txt (40.1 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace
myth6.log (14.2 KB) - added by tapio.sami@… 10 years ago.
additional crashes with perhaps better backtrace

Download all attachments as: .zip

Change History (24)

Changed 10 years ago by tapio.sami@…

Attachment: gdb.txt added

backtrace

comment:1 Changed 10 years ago by tapio.sami@…

Forgot to say, the DV video is imported with program named "kino". It plays with totem, mplayer. Well, atleast the video, sound is missing also with those programs... might be something wrong with the kino options..

comment:2 Changed 10 years ago by tapio.sami@…

The audio is fine with mplayer and totem. The missing audio was user error. :) (muted output)

comment:3 Changed 10 years ago by robertm

Component: Plugin - MythVideoMythTV - Video Playback
Milestone: 0.22unknown
Owner: changed from Anduin Withers to Isaac Richards

Changed 10 years ago by tapio.sami@…

Attachment: gdb.2.txt added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: myth.log added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: gdb2.txt added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: myth2.log.bz2 added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: gdb3.txt added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: myth3.log added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: gdb4.txt added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: myth4.log added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: gdb5.txt added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: myth5.log added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: gdb6.txt added

additional crashes with perhaps better backtrace

Changed 10 years ago by tapio.sami@…

Attachment: myth6.log added

additional crashes with perhaps better backtrace

comment:4 Changed 10 years ago by tapio.sami@…

Now I've made the backtraces with starting the mythfrontend thru gdb. So backtrace should be complete. I did it according to instructions at myth website. But the frontend does not die after the segfault. Ctrl+c does nothing. I ended up with kill -9 the gdb and mythfrontend process.

Anyway, are these backtraces better?

comment:5 Changed 10 years ago by tapio.sami@…

I forgot, I've updated since the initial bugreport, the latest backtraces are created with:

htpc:/home/mythtv# mythbackend --version Please include all output in bug reports. MythTV Version : 21210M MythTV Branch : trunk Network Protocol : 46 Library API : 0.22.20090811-1 QT Version : 4.5.2 Options compiled in:

linux debug using_alsa using_backend using_dvb using_frontend using_hdpvr using_iptv using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

comment:6 Changed 10 years ago by stuartm

Can you try without vdpau? Using the Standard decoder and xv-blit renderer?

comment:7 Changed 10 years ago by tapio.sami@…

First try showed the picture for few seconds, ended up with error box saying something like "serious error in video output". Second and third try ended up with "failed to reinitialize video output". Fourth also, but it played several seconds before it. Maybe 5-7s... Logs says:

2009-08-11 17:30:13.500 RingBuf?(/media/mythvideo/home_videos/nauha 003.dv): OpenFile?(/media/mythvideo/home_videos/nauha 003.dv, 12) 2009-08-11 17:30:13.502 RingBuf?(/media/mythvideo/home_videos/nauha 003.dv): CalcReadAheadThresh?(0 KB)

-> threshhold(64 KB) min read(0 KB) blk size(32 KB)

2009-08-11 17:30:13.514 TV: StartPlayer?(0, Watching Video, main) -- begin 2009-08-11 17:30:13.515 playCtx, Error: Attempting to setup a player, but it already exists. 2009-08-11 17:30:13.515 TV: StartPlayer?(0, Watching Video, main) -- end error 2009-08-11 17:30:13.515 TV: HandleStateChange?(0) -- end 2009-08-11 17:30:18.488 TV: StartTV -- process events end 2009-08-11 17:30:18.488 TV: StartTV -- process events 2 begin 2009-08-11 17:30:18.488 TV: StartTV -- process events 2 end 2009-08-11 17:30:18.489 TV::~TV() -- begin 2009-08-11 17:30:18.489 TV::~TV() -- lock 2009-08-11 17:30:18.740 TV::~TV() -- end 2009-08-11 17:30:18.743 TV: StartTV -- end

So, it does not show the videos as it should, but it does not crash the frontend as with vdpau.

Anything else? I'm happy to help with debugging...

comment:8 Changed 10 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Status: newaccepted

does the video play with ffplay? can you make a sample available?

Either the video is triggering a strange bug or it is invaled/damaged

comment:9 Changed 10 years ago by Tapio.Sami@…

Yes, the videos play with ffplay. I'm in the process of uploading couple of sample files to a free file sharing service. The link should be http://www.4shared.com/dir/18685654/d0534a68/sharing.html if I have figured the site right.

I think it's a bug, cause ffplay, mplayer and totem is playing these videos OK. I have over 500GB of these videos, so far myth has not played correctly any of the ones I've tried. And every one is playing OK with other software.

Happy to provide more help in fixing this, though my response time might be a bit longer now... I'm abroad on a work trip.

comment:10 Changed 10 years ago by Janne Grunau

Milestone: unknown0.22

reproduceable (not the segfault but problems) with your samples, thanks. I'll look into it.

comment:11 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [22166]) do not handle the default value of mpeg_version as MPEG codec. Fixes #6780

Fixes DV playback and probably playback of other non mpeg/mainstream codecs.

Note: See TracTickets for help on using tickets.