Opened 11 years ago

Closed 11 years ago

#6903 closed defect (invalid)

Number of encoders is increased too if you change other settings of a TV Card in mythtv-setup

Reported by: yianniv Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If I change a setting in the TV card properties (/dev/dvb/adapter 1 instead of 0 for example) and save the changes with "Finish", the number of encoders for the device is increased by one. I have to return to the properties page again and decrease the number of simultaneous recordings to the previous value.

Additionally, when a card is deleted and with it the total number of encoders it has (especially for the DVB cards that can support more than one recording, and then re-added, the now new device has different device number (encoders 2,3,4 were replaced by 21,22,23 for example, if I have 20 encoders on the system). This way the encoder numbers are not consecutive and gaps in the encoder numbers exist. I had to do this during the s2api changes. Can they be tidied up without deleting all TV cards?

TIA,

Yianni.

Please include all output in bug reports. MythTV Version : 21487 MythTV Branch : trunk Network Protocol : 48 Library API : 0.22.20090821-1 QT Version : 4.4.3 Options compiled in:

linux release using_oss using_alsa using_arts using_jack using_backend using_directfb using_dvb using_firewire using_frontend using_hdpvr using_iptv using_ivtv using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Change History (1)

comment:1 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

not a bug

Note: See TracTickets for help on using tickets.