Opened 10 years ago

Closed 10 years ago

#7025 closed defect (invalid)

diseqc rotor wrong control

Reported by: mr.krash@… Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: MythTV - DVB Version: head
Severity: medium Keywords: diseqc rotor
Cc: Ticket locked: no

Description

Hi, I have a problem with the control of rotor: when I try to scan, any satellite and any frequency, rotor turn all to west. If I retry, rotor come back slowly but stop after timeout. Next try, it go again to west. Needless to say that with other systems working properly. My specs is:

  • MythTV: last svn (21756);
  • Rotor: SM3D12;
  • SatCard?: Skystar 2 PCI;

Thank's in advance. mr.krash

Attachments (1)

mythtv_log.txt (8.4 KB) - added by mr.krash@… 10 years ago.
Debug log of failed rotor configuration

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Janne Grunau

Status: newinfoneeded_new
Version: unknownhead

what type of rotor? are you sure it correctly configured?

please attach a mythtv-setup -v most log.

Changed 10 years ago by mr.krash@…

Attachment: mythtv_log.txt added

Debug log of failed rotor configuration

comment:2 Changed 10 years ago by mr.krash@…

Hi. Rotor -> SM3D12 with DiSEqC 1.2 positioner, GoToX, DiSEqC 1.3, USALS compatible. The rotor is correctly configured, I use it with an ABCom IpBox? PVR250S. On MythTV i have configured Rotor (diseqc 1.3) with 1 LNB and My position (lon 14,52 - lat 36,95). In input connection i have insert a lon of my preferred sat (Hotbird 13°) and i ìn scan section i have insert a sicured transponder.

comment:3 Changed 10 years ago by Dibblah

You seem to have a very low tuning / signal timeout applying here. Can you check the entries in mythtv-setup, capture card setup please? For -s with a rotor, these should be longer than your rotor can possibly take to transit.

comment:4 Changed 10 years ago by mr.krash@…

I have changed timeout and now is set to max (60000/65000), but don't change nothing. It's necessary that dish turn all when position of my sat is only -1,72 from 0 on graduate scale of rotor?

comment:5 Changed 10 years ago by Janne Grunau

Status: infoneeded_newnew

I think you've configured the input to 13 degrees west. btw the correct orbital position of hotbird is 13.5E

comment:6 Changed 10 years ago by mr.krash@…

I have inserted only 13 without west or est. Now I have also test with 13.5, but nothing.

comment:7 Changed 10 years ago by mr.krash@…

I have changed in input connection the coord of my sat. Now if I set 13 and orienatl hemisphere, in log I see the correct diseqc command that set dish to 13 (Azimuth -1,72..). But dish don't move...

comment:8 Changed 10 years ago by mr.krash@…

Ok, problem (maybe) solved. In input connections, when i must set grade, i must set also emisphere that it's relative to satellite and not to my position. Now i have set oriental and mythtv send correct diseqc command. Tank you for your support.

comment:9 Changed 10 years ago by Dibblah

Resolution: invalid
Status: newclosed

Thank you for following up on this. You are one of very few rotor users - As far as I know, no devs have rotors, therefore bugs may not be noticed in this code.

If this problem is not in fact just a configuration issue, please comment on this ticket and it will be reopened.

Note: See TracTickets for help on using tickets.