Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7140 closed defect (fixed)

Selecting record while watching LiveTV ruins the picture on playback, pvr150

Reported by: arizonamythtv@… Owned by: Janne Grunau
Priority: major Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords: pvr150
Cc: Ticket locked: no

Description

While watching livetv and then selecting record, when trying to playback the show through the watch recording screen results in an unusable television show.

You can see an example at the following link.

http://www.youtube.com/watch?v=qS81djM3eRQ

I've also attached a log file of the playback.

Attachments (3)

log2.txt.Z (247.4 KB) - added by anonymous 10 years ago.
mythtv_revert_ffmpeg_r19000_and_r19272.diff (713 bytes) - added by tralph11@… 10 years ago.
Patch to determine if related to ffmpeg regression
mythtv_apply_ffmpeg_r20017.diff (691 bytes) - added by tralph11@… 10 years ago.
proper fix from the ffmpeg developers

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by anonymous

Attachment: log2.txt.Z added

Changed 10 years ago by tralph11@…

Patch to determine if related to ffmpeg regression

comment:1 Changed 10 years ago by tralph11@…

arizonamythtv: Please try the attached patch and report back if it helps or not.

comment:2 Changed 10 years ago by arizonamythtv@…

I'm currently using packages. I'll have to get the necessary dependencies and compile. I'll do it this weekend.

comment:3 Changed 10 years ago by arizonamythtv@…

I was able to compile and I can confirm that the patch fixes the issue.

Changed 10 years ago by tralph11@…

proper fix from the ffmpeg developers

comment:4 Changed 10 years ago by tralph11@…

arizonamythtv: awesome! thanks for testing. Janneg just informed me that the ffmpeg devs recently checked in a change to properly address the problem. Could you remove the previous patch and apply the new one I just posted and let us know if it also works? Thanks.

comment:5 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

(In [22043]) increase number of probe packets and probe buffer size to fix detection of ivtv recordings

backport of ffmpeg changeset 20017. Refs #4862, Closes #7140

comment:6 Changed 10 years ago by arizonamythtv@…

I removed the first patch and applied the second. Unfortunately, the problem is still occurring with the second patch.

comment:7 Changed 10 years ago by tralph11@…

arizonamythtv: Did you perform a make clean before you rebuilt? If not, would you mind doing a make clean; make install to just be 100% certain the most recent patch is compiled in? If it still fails could you provide a small 10MB sample. Just run the following command against the recording:

dd if=/path/to/file.mpg of=sample.mpg bs=1024 count=10000

and upload to http://filebin.ca/

Thanks!

comment:8 Changed 10 years ago by arizonamythtv@…

Okay, I must've forgot to do a make clean. I just recompiled with the patch after make clean and I tested 10 recordings and none of them failed. Thanks for the quick fix and sorry for the added static at the end.

comment:9 Changed 10 years ago by Janne Grunau

a patch shouldn't be necessary after [22043]

Note: See TracTickets for help on using tickets.