Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 5 years ago

Closed 4 years ago

#7164 closed defect (invalid)

LiveTV: Channel change restricted to same multiplex

Reported by: tralph11@… Owned by: ijr
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

LiveTV is restricted to the same multiplex/tuner after the following sequence is followed.

  • During LiveTV select record with the 'r' key
  • Exit LiveTV
  • Return to LiveTV while the program is still recording

The "Browse all channels" and "Avoid conflicts between live TV and scheduled shows" options are enabled.

I have 2 ivtv recorders (tuners 1, 2) and 2 dvb recorders (tuners 9,10,11,12). The 2 dvb recorders user multi-rec and are configured to support 2 recordings each. So in all I have tuners 1, 2, {9,10} and {11,12}.

With no recordings in progress when I enter LiveTV it seems to almost always select tuner 12. When I press 'r' to record, exit and the return to LiveTV it will put me on tuner 11 which is the same dvb card/multiplex as tuner 12. At this point I can not change to any channel available to the dvb tuners even though tuners 9 and 10 are available. However two work-arounds exist.

  1. I can select channels available to my ivtv tuners 1 and 2. After I switch to one of those channels I can then change channels to any dvb channel.
  1. I can use Menu->Switch Input and force a change to tuner 9 or 10 and then everything works normal again.

Attachments (2)

mbe_browse_stuck_mplex.log (51.2 KB) - added by tralph11@… 5 years ago.
mythbackend log using -v record,channel,siparser
mfe_browse_stuck_mplex.log (50.9 KB) - added by tralph11@… 5 years ago.
mythfrontend log using -v playback

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by tralph11@…

mythbackend log using -v record,channel,siparser

Changed 5 years ago by tralph11@…

mythfrontend log using -v playback

comment:1 Changed 5 years ago by tralph11@…

Possible dupe of #4989

Discussion here:

http://www.gossamer-threads.com/lists/mythtv/dev/369358#369358

Probably best to go ahead and close since it's been looked into already.

comment:2 Changed 4 years ago by anonymous

I have the same issue on Win Trunk

comment:3 Changed 4 years ago by stuartm

  • Resolution set to invalid
  • Status changed from new to closed
  • Ticket locked set

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.