Opened 10 years ago

Closed 10 years ago

#7219 closed defect (fixed)

Segmentation fault in Programme Guide during LiveTV/recording.

Reported by: markk Owned by: stuartm
Priority: minor Milestone: 0.22
Component: MythTV - User Interface Library Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

To reproduce, start playback and enter the programme guide. Bring up the popup menu with M and press S to exit the guide. Press S again and the popup menu is still visible and any attempt to clear it produces a crash.

Change History (1)

comment:1 Changed 10 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [22163]) Prevent exiting the guide when a popup is visible, normally this wouldn't be a problem since the popup would receive the ESCAPE action instead, but the guide can also be exited with the GUIDE action. Fixes #7219

Note: See TracTickets for help on using tickets.