Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7322 closed defect (fixed)

JumpPoints dont work in mythvideo gallery view or during gallery view playback

Reported by: oobe.trouble@… Owned by: Anduin Withers
Priority: minor Milestone: 0.23
Component: Plugin - MythVideo Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

to reproduce switch to gallery view then go into a few folders and press a jump point keybinding i.e main menu or recordings

it will just move you up one directory this also happens during video playback if using gallery view.

can be reproduced in trunk and release-0-22-fixes

Attachments (1)

mythvideo_jumppoints.patch (490 bytes) - added by Jim Stichnoth <stichnot@…> 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Jim Stichnoth <stichnot@…>

Attachment: mythvideo_jumppoints.patch added

comment:1 Changed 10 years ago by Jim Stichnoth <stichnot@…>

Such a minuscule patch, such a huge delta WAF...

comment:2 Changed 10 years ago by anonymous

wow thanks heaps Jim Stichnoth I applied it to 22-fixes works cleanly and really well you made my day been waiting for someone to fix this .

comment:3 Changed 10 years ago by Stuart Auchterlonie

Component: MythTV - GeneralPlugin - MythVideo
Milestone: unknown0.23
Owner: changed from Isaac Richards to Anduin Withers
Version: unknown0.22-fixes

comment:4 Changed 10 years ago by Jim Stichnoth <stichnot@…>

Sorry -- in my excitement and haste I forgot to untabify the patch. I won't bother resubmitting since it's only a one-line patch.

I got to learn how JumpPoints? are implemented. Apparently an escape-key event is synthesized and continually propagated until the main menu is reached, and then the jump point is executed. This requires cooperation from the escape-key handler of each component/screen, which is supposed to check whether we are trying to exit out to the main menu. Without this patch, MythVideo? isn't doing that check, so if you're at a screen that takes more than one escape key to exit out of MythVideo?, JumpPoint? processing gets messed up.

comment:5 Changed 10 years ago by stuartm

The implementation of jumppoints could be vastly improved, generating keypresses is sub-optimal. With mythui we can instead just iterate down the stacks closing screens until we reach the main menu.

comment:6 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

(In [23085]) Fixes #7322. Allow MythVideo? views with a directory-style hierarchy to respond properly to JumpPoint? actions. Patch is a workaround until JumpPoints? are reworked in the future. Thanks to Jim Stichnoth for the patch.

comment:7 Changed 10 years ago by Janne Grunau

(In [23533]) configure: die with unknown --arch argument. Refs #7322

comment:8 Changed 10 years ago by Janne Grunau

(In [23536]) libavformat: upstream handles DVB_TELETEXT as subtitle codec type. Refs #7322

comment:9 Changed 10 years ago by Janne Grunau

(In [23537]) libavformat: set codec->sub_id for DVB subtitles

Regression in [23525], Refs #7322

Note: See TracTickets for help on using tickets.