Opened 10 years ago

Closed 3 years ago

#7399 closed defect (Invalid)

HD playback using XVideo locks up X server

Reported by: pete-mythtv@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: low Keywords:
Cc: Ticket locked: yes

Description

This behavior started immediately after updating from 0.22.0+fixes22517 to fixes22547, and still occurs in fixes22550. Running Mythbuntu 9.04 x86_64, plus daily 0.22-trunk builds.

Playback of HD recordings using XVideo locks up the X server (nvidia proprietary driver 180 on 7050PV chip) after a second or two. Tried both ffmpeg & libmpeg2. X server process pegs the CPU at 100%, mythfrontend.real at 35%, screen frozen. Requires killing mythfrontend. OpenGL works, but results in jerky playback on my system, so I really need to get back to a working XVideo rendering. (XvMC never worked reliably on my hardware, but it also locks up now.)

# mythfrontend.real --version Please include all output in bug reports. MythTV Version : 22550 MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091008-1 QT Version : 4.5.0 Options compiled in:

linux profile using_oss using_alsa using_pulse using_jack using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Change History (6)

comment:1 in reply to:  description Changed 10 years ago by pete-mythtv@…

Addendum: Lock-up occurs with 720 & HD sources; playback of SD recordings is fine, with my default ffmpeg-XVideo setting.

comment:2 Changed 10 years ago by danielk

Milestone: 0.22unknown
Priority: majorminor
Severity: highlow
Status: newinfoneeded_new
Version: 0.22rc1head

Need a backtrace, see TicketHowTo -- this is probably not a MythTV bug, but without a backtrace it is impossible to tell.

comment:3 Changed 10 years ago by pete-mythtv@…

Seems to be caused by a bad interaction between nvidia X server, x11vnc server, and high-bandwidth screen buffer updates. Problem resolved by disabling vnc service. Agree that it's not a MythTV bug; ok to close.

comment:4 Changed 10 years ago by sphery

Resolution: invalid
Status: infoneeded_newclosed

Thanks for the quick response.

comment:5 in reply to:  description Changed 3 years ago by Jrcjakhar301085@…

Resolution: invalid
Status: closednew

Replying to pete-mythtv@…:

This behavior started immediately after updating from 0.22.0+fixes22517 to fixes22547, and still occurs in fixes22550. Running Mythbuntu 9.04 x86_64, plus daily 0.22-trunk builds.

Playback of HD recordings using XVideo locks up the X server (nvidia proprietary driver 180 on 7050PV chip) after a second or two. Tried both ffmpeg & libmpeg2. X server process pegs the CPU at 100%, mythfrontend.real at 35%, screen frozen. Requires killing mythfrontend. OpenGL works, but results in jerky playback on my system, so I really need to get back to a working XVideo rendering. (XvMC never worked reliably on my hardware, but it also locks up now.)

# mythfrontend.real --version Please include all output in bug reports. MythTV Version : 22550 MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091008-1 QT Version : 4.5.0 Options compiled in:

linux profile using_oss using_alsa using_pulse using_jack using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

comment:6 Changed 3 years ago by stuartm

Resolution: Invalid
Status: newclosed
Ticket locked: set
Note: See TracTickets for help on using tickets.