Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#7531 closed defect (fixed)

Mythweb - Music streaming fails

Reported by: John L. Poole <jlpoole@…> Owned by: Rob Smith
Priority: minor Milestone: 0.23
Component: Plugin - MythWeb Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I previously filed a ticket relating to this problem under version 0.21, see Ticket 7370.

On a Gentoo (AMD64) I have:

# eix mythtv
[i] media-plugins/gst-plugins-mythtv
     Available versions:  (0.10)  0.10.11!t ~0.10.14!t
     Installed versions:  0.10.11(0.10)!t(09:49:08 11/08/09)
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         plugin for gstreamer

[i] media-tv/mythtv
     Available versions:  0.21_p19961-r2 (~)0.21_p20877 (~)0.22_p22764 (~)0.22_p22772 {aac alsa altivec autostart debug directv dvb dvd fftw ieee1394 jack lcd lirc mmx opengl perl pulseaudio python tiff vdpau video_cards_nvidia video_cards_via xvmc}
     Installed versions:  0.22_p22772(09:26:27 11/08/09)(mmx perl python -alsa -altivec -autostart -debug -directv -dvb -dvd -fftw -ieee1394 -jack -lcd -lirc -pulseaudio -tiff -vdpau -video_cards_nvidia -xvmc)
     Homepage:            http://www.mythtv.org
     Description:         Homebrew PVR project
 # eix mythweb
[i] www-apps/mythweb
     Available versions:
        (0.21_p17573)   0.21_p17573
        (0.21_p20323)   (~)0.21_p20323
        (0.22_rc22667)  (~)0.22_rc22667
        {vhosts}
     Installed versions:  0.21_p20323(0.21_p20323)(05:13:17 11/07/09)(-vhosts)
                          0.22_rc22667(0.22_rc22667)(09:32:15 11/08/09)(-vhosts)
     Homepage:            http://www.mythtv.org
     Description:         PHP scripts intended to manage MythTV from a web browser.

The web interface appears to be working fine. I had previously ripped a CD under the 0.21 install using MP3.

When I try to access the MP3 via the web interface, I am unsuccessful. I have tried using WinAmp? and get an error: "Error syncing to stream"

With the VLC client, I have a log:

main debug: processing request item Symphony No 1 in D, D 82 -1) Adagio - Allegro vivace node Playlist skip 0
main debug: resyncing on Symphony No 1 in D, D 82 -1) Adagio - Allegro vivace
main debug: Symphony No 1 in D, D 82 -1) Adagio - Allegro vivace is at 0
main debug: starting new item
main debug: creating new input thread
main debug: Creating an input for 'Symphony No 1 in D, D 82 -1) Adagio - Allegro vivace'
main debug: thread (input) created at priority 1 (../.././src/input/input.c:230)
main debug: thread started
main debug: using timeshift granularity of 50 MBytes
qt4 debug: IM: Setting an input
main debug: using timeshift path 'C:\DOCUME~1\jlpoole\LOCALS~1\Temp'
main debug: `http://192.168.168.20/mythweb/music/stream?i=1' gives access `http' demux `' path `192.168.168.20/mythweb/music/stream?i=1'
main debug: creating demux: access='http' demux='' path='192.168.168.20/mythweb/music/stream?i=1'
main debug: looking for access_demux module: 0 candidates
main debug: no access_demux module matched "http"
main debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
main debug: creating access 'http' path='192.168.168.20/mythweb/music/stream?i=1'
main debug: looking for access module: 2 candidates
access_http debug: http: server='192.168.168.20' port=80 file='/mythweb/music/stream?i=1
main debug: net: connecting to 192.168.168.20 port 80
main debug: connection: Resource temporarily unavailable
qt4 debug: Updating the geometry
qt4 debug: Updating the geometry
main debug: connection succeeded (socket = 984)
access_http debug: protocol 'HTTP' answer code 206
access_http debug: Server: Apache
access_http debug: Accepting Cookie: mythweb_id=64274889f08de2435cf6364f28e2f2ab; expires=Mon, 08-Nov-2010 18:42:52 GMT; path=/
access_http debug: Pragma: no-cache
access_http debug: Accepting Cookie: mythweb_tmpl=default; expires=Tue, 19-Jan-2038 03:14:07 GMT; path=/mythweb/
access_http debug: Accepting Cookie: mythweb_skin=default; expires=Tue, 19-Jan-2038 03:14:07 GMT; path=/mythweb/
access_http debug: stream size=244,pos=0,remaining=244
access_http debug: this frame size=244
access_http debug: Content-Type: application/octet-stream
main debug: using access module "access_http"
main debug: TIMER module_need() : 64.000 ms - Total 64.000 ms / 1 intvls (Avg 64.000 ms)
main debug: Using AStream*Stream
main debug: pre buffering
main debug: received first data after 0 ms
main debug: pre-buffering done 244 bytes in 0s - 238281 kbytes/s
main debug: looking for stream_filter module: 2 candidates
main debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
main debug: looking for stream_filter module: 1 candidate
main debug: using stream_filter module "stream_filter_record"
main debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
main debug: creating demux: access='http' demux='' path='192.168.168.20/mythweb/music/stream?i=1'
main debug: looking for demux module: 50 candidates
ts error: cannot peek
lua debug: Trying Lua scripts in C:\Documents and Settings\jlpoole\Application Data\vlc\lua\playlist
lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\\lua\playlist
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\anevia_streams.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\appletrailers.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\bbc_co_uk.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\break.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\canalplus.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\cue.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\dailymotion.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\france2.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\googlevideo.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\joox.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\koreus.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\lelombrik.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\megavideo.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\metacafe.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\mpora.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\vimeo.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\youtube.lua
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\youtube_homepage.lua
lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\\share\lua\playlist
avformat debug: couldn't guess format
vobsub debug: this doesn't seem to be a vobsub file
ps warning: this does not look like an MPEG PS stream, continuing anyway
main debug: using demux module "ps"
main debug: TIMER module_need() : 9.000 ms - Total 9.000 ms / 1 intvls (Avg 9.000 ms)
main debug: looking for a subtitle file in C:\Program Files\Mozilla Firefox\
main debug: `http://192.168.168.20/mythweb/music/stream?i=1' successfully opened
ps warning: garbage at input, trying to resync...
main debug: EOF reached
main debug: removing module "ps"
main debug: removing module "stream_filter_record"
main debug: removing module "access_http"
main debug: waitpipe: object killed
main debug: thread ended
main debug: dead input
main debug: thread times: real 0m0.093750s, kernel 0m0.000000s, user 0m0.031250s
main debug: changing item without a request (current 0/1)
main debug: nothing to play
qt4 debug: IM: Deleting the input
qt4 debug: Updating the geometry
qt4 debug: Updating the geometry
main debug: TIMER input launching for 'Symphony No 1 in D, D 82 -1) Adagio - Allegro vivace' : 79.000 ms - Total 79.000 ms / 1 intvls (Avg 79.000 ms)

What may I provide to get you further details on the problem?

Attachments (1)

mythweb_music_streaming.patch (524 bytes) - added by Raymond Wagner 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by anonymous

Could this be an issue about the files themselves as ripped? Is there a recommended setting for paranoia (?), the CD ripper program, that can be used as a control?

comment:2 Changed 10 years ago by John L. Poole <jlpoole@…>

I've confirmed the files I'm trying to stream do play in the KDE Juk player on the machine MythTV is installed.

comment:3 Changed 10 years ago by Deyan <mythtv@…>

I get the exact same behavior with WinAmp? and VLC. Will try on my Linux laptop tonight, but at least my Windows XP machine cannot play remotely (it's on the same network so no firewalls, NAT, etc.).

comment:4 Changed 10 years ago by Johan Maes <on4qz@…>

I had a look at ...mythweb/modules/music/stream.php. The problem is that Master_Host is empty. To test it I replaced in line 105: readfile("http://$Master_Host:$port..... with readfile("http://localhost:$port..... and everything seems to work. This is just to cure the symptoms (it works) but one should try to find why the global $Master_Host is empty.

Changed 10 years ago by Raymond Wagner

comment:5 Changed 10 years ago by Raymond Wagner

I can't seem to find any existing global that provides the master backend IP, so this patch just pulls it new from the database.

comment:6 Changed 10 years ago by Stuart Auchterlonie

Bumping open 0.22 milestone tickets to 0.24

comment:7 Changed 10 years ago by Stuart Auchterlonie

Milestone: 0.220.24

comment:8 Changed 10 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [23675]) Fixes #7531, this fixes the missing mbe ip in mythmusic

comment:9 Changed 10 years ago by stuartm

Milestone: 0.240.23

comment:10 Changed 9 years ago by Bradley Ford <wombo1@…>

I have been having problems streaming music from Mythweb. I have identified that a change similar to comment 4 needs to occur again.

Line 104 needs to change from

$Master_Host = get_backend_setting('MasterServerIP');

To

$Master_Host = get_backend_setting('BackendServerIP');

BTW I did check my 'MasterServerIP' setting from within Mythweb and it was filled out correctly; but upon checking the file that was being access it was clear that the IP address was not being passed through. When 'MasterServerIP' was changed to 'BackendServerIP' everything started working correctly.

comment:11 Changed 8 years ago by Wesleyb@…

Agree with Bradley. I recently upgraded from 0.23.1 to 0.24+Fixes and this same issue occurred.

I was able to use either of the changes to /usr/share/mythtv/mythweb/modules/music/stream.php to fix the problem:

Substitute "$Master_Host" with "localhost" on line 105

or

Substitute "MasterServerIP" with "BackendServerIP" on line 104

Note: See TracTickets for help on using tickets.