Opened 10 years ago

Closed 10 years ago

#7703 closed defect (fixed)

mythmusic no longer display playing time

Reported by: svens@… Owned by: danielk
Priority: critical Milestone: 0.23
Component: Plugin - MythMusic Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Since a few days, mythmusic no longer displays the Title Play time on screen, and doesn't advance to the next Track when finished playing the current Track. I'm using the latest svn rev.

Attachments (2)

mythevent_clone_mythtv_r22953.patch (485 bytes) - added by mythtv@… 10 years ago.
mythevent_clone_mythplugins_r22953.patch (816 bytes) - added by mythtv@… 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by stuartm

Milestone: unknown0.23
Priority: minorcritical
Severity: mediumhigh

comment:2 Changed 10 years ago by mythtv@…

This problem was caused by 22945, which changed the prototype of the MythEvent::clone() virtual function breaking the overrides from the audio system's Output event and MythMusic's Decoder event classes. The attached patches resolve these problems.

Changed 10 years ago by mythtv@…

Changed 10 years ago by mythtv@…

comment:3 Changed 10 years ago by stuartm

Owner: changed from stuartm to danielk
Status: newassigned

comment:4 Changed 10 years ago by danielk

Resolution: fixed
Status: assignedclosed

This was fixed by [22954], but missed by the trac hook.

Note: See TracTickets for help on using tickets.