Opened 10 years ago

Closed 10 years ago

#7750 closed defect (wontfix)

PulseAudio coexistance

Reported by: phil.ingram@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am experiencing an anomaly between MythTV and PulseAudio? on Fedora 12. My steps to reproduce are as follows for a default system installation and mythtv from rpmfusion.org. This problem was also affecting me with F11 but I never had the thought to try this work around..

  1. Boot system and login
  1. Start "mythfrontend"
  1. Watch a prerecorded show or start live tv
    • Audio present but no volume control
  1. Flick to another face and start "pavucontrol", move volume sliders then flick back to mythfrontend - leave pavucontrol open.
    • internal volume controls now work
  1. Stop playback and return to main menu.
    • any sounds that have been triggered since the starting of mythfrontend should now be played in a cacophony of sound.
  1. Go back to watching a prerecorded episode
    • no volume and the volume slider is reported by mythfrontend as 0% and can not be changed.
  1. return to menu and close pavucontrol
  1. start watching again
    • audio present but no volume control.
    • repeating step 4 fixes the issue.

Audio output device = ALSA:surround51 Max channels = 5.1

Mixer device = ALSA:default Mixer control = Master

[mythtv@fe ~]$ pulseaudio --version pulseaudio 0.9.21

[mythtv@fe ~]$ mythfrontend --version Please include all output in bug reports. MythTV Version : 0.22 MythTV Branch : tags/release-0-22 Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.3 Options compiled in:

linux release using_oss using_alsa using_pulse using_arts using_jack using_backend using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

[mythtv@myth ~]$ mythbackend --version Please include all output in bug reports. MythTV Version : 0.22 MythTV Branch : tags/release-0-22 Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.3 Options compiled in:

linux release using_oss using_alsa using_pulse using_arts using_jack using_backend using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Change History (2)

comment:1 Changed 10 years ago by Saviq

MythTV 0.22 suspends PulseaAudio? when it's running so no pulseaudio-related stuff is relevant.

You could set 'EXPERIMENTALLY_ALLOW_PULSEAUDIO=1" environment variable, pulseaudio won't be suspended in that case.

comment:2 Changed 10 years ago by Raymond Wagner

Resolution: wontfix
Status: newclosed

While a PulseAudio? output method has been written, it suffers from poor audio sync, and has such been disabled except for testing and development. Since PulseAudio? does not actually support hardware on its own, instead relying on ALSA, MythTV's only recourse is to disable PulseAudio? while running, and access ALSA directly. This results in the deficiencies in the rest of the system that you have outlined above, however most users running MythTV on a dedicated machine will not experience these.

Once the sync issues have been resolved, this behavior and associated problems will be removed, and MythTV will be allowed to use PulseAudio?. The ticket to follow for that is #7496.

Note: See TracTickets for help on using tickets.