Opened 10 years ago

Closed 9 years ago

#7801 closed defect (fixed)

mythweb 0.22 cannot stream a file, while it's being recorded.

Reported by: glemsom@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.22-fixes
Severity: medium Keywords: mythweb stream recording
Cc: Ticket locked: no

Description

With the old mythweb 0.21 - you could watch a recording, WHILE it was still being recorded.
This is no longer true with 0.22 of mythweb.

Let's take an example:

  • mythbackend starts recording a 1 hour show.
  • 20 minutes in the recording, I decided I want to watch the show - so I stream the recording using mythweb.

In 0.22, when you hit the 20 minutes mark - where you "started to watch" the show, mythweb will not stream anymore data. You will have to re-open the stream to get the last part of the show.

This WAS working fine in 0.21. (You could even skip forward, but ofcause not any longer then the actual recording).

Attachments (1)

fix-eof-0.23.patch (824 bytes) - added by glemsom@… 9 years ago.
Backported to 0.23

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by glemsom@…

This is seen in the apache error log:

Negative length at modules/stream/stream_raw.pl line 116.
Compilation failed in require at modules/stream/handler.pl line 42.
Compilation failed in require at /var/www/localhost/htdocs/mythweb/mythweb.pl line 65.

comment:2 Changed 10 years ago by robertm

Resolution: wontfix
Status: newclosed

Watching of in-progress recordings works for me. What you're seeing is a potential downside of the new flowplayer code, but as it's unsupported code anyway...

comment:3 Changed 10 years ago by anonymous

Resolution: wontfix
Status: closednew

I can confirm this regression bug in Mythweb 0.22!
A simple test:
1: Start a 1 hour recording, and let it record for a few minutes.
2: wget the "Direct download" URL from mythweb.

Actual result: The transfer is terminated when the end of file is reached - and only the few minutes of the recording is downloaded.

Expected result: (As it was with 0.21)
The transfer will continue till the recording is done. (though at a lower speed)

comment:4 Changed 9 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [24917]) Fixes #7801, this should recalculate the EOF correctly when downloading a inprogress recording via stream_raw

Changed 9 years ago by glemsom@…

Attachment: fix-eof-0.23.patch added

Backported to 0.23

Note: See TracTickets for help on using tickets.