Opened 10 years ago

Closed 10 years ago

#7805 closed defect (fixed)

immediate segfault when selecting "Watch Videos"

Reported by: Klavs Klavsen <kl@…> Owned by: Anduin Withers
Priority: major Milestone: unknown
Component: Plugin - MythVideo Version: 0.22-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

When I select "Media library"->"Watch Videos" mythfrontend immediately segfaults.

I'm running mythbuntu 0.22 with myth* packages from their weeklybuilds: http://weeklybuilds.mythbuntu.org/mythbuntu/trunk-0.22/ubuntu

mythbuntu package version:0.22.0+fixes23003-0ubuntu0+mythbuntu3

mythtv-dbg is installed.

I've attached a backtrace - which doesn't tell me anything - but I've never seen a backtrace before.. I hope it helps you - or perhaps you can tell me what to do differently to debug.

Attachments (2)

gdb-mythfrontend.txt (39.7 KB) - added by Klavs Klavsen <kl@…> 10 years ago.
gdb-mythvideo-settings.txt (34.9 KB) - added by anonymous 10 years ago.
backtrace from enterint mythvideo settings

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by Klavs Klavsen <kl@…>

Attachment: gdb-mythfrontend.txt added

comment:1 Changed 10 years ago by Klavs Klavsen <kl@…>

I forgot to mention, that this problem does not occur on any of my other frontends (which are not using packages from mythbuntu weeklybuilds though - as they are Debian Sid and Ubuntu 9.04 machines) using the same backend.

comment:2 Changed 10 years ago by robertm

Status: newinfoneeded_new

Not that this isn't a bug in its own right, but can you check and see if the video directory is blank?

Utilities/Setup?->Setup->Video Settings->General

I suspect that this would go away if you populated the field (if it is indeed blank). Mythbuntu is blanking out this field in their own DB modifications, I believe, which I suspect is causing this.

comment:3 Changed 10 years ago by Klavs Klavsen <kl@…>

If I choose "Video Settings" it also crashes instantly. both with the "weekly build" from mythbuntu and with orig. ubuntu packages.

can I provide more info?

comment:4 Changed 10 years ago by robertm

Klavs,

Can you get me a backtrace for the crash trying to enter the settings also, then, please?

Thanks.

comment:5 Changed 10 years ago by kl@…

I just confirmed that mythvideo is same version as the rest (0.22.0+fixes22594-0ubuntu1 - I reverted to this, to get mythtv-dbg - it isn't in mythbuntu weeklybuilds it seems).

I've attached the backtrace from entering the video settings.

Changed 10 years ago by anonymous

Attachment: gdb-mythvideo-settings.txt added

backtrace from enterint mythvideo settings

comment:6 Changed 10 years ago by robertm

(In [23083]) Refs #7805. Not entirely certain this will fix the issue but it's the first thing that jumps out at me. Check to make sure the dirlist has any values before attempting to operate on it.

comment:7 Changed 10 years ago by robertm

(In [23084]) Refs #7805. Backport what should be an otherwise harmless change so that ticket reporter can test possible fix with nightly pacakged builds.

comment:8 Changed 10 years ago by robertm

Klavs,

Once r23804 hits your nightly builds, can you please test and report back on whether in fixed/changed your issue?

Thanks.

comment:9 Changed 10 years ago by Klavs Klavsen <kl@…>

I will. Thank you for the fix..

comment:10 Changed 10 years ago by kl@…

23084 has landed - and it works like a charm. The field for the path to the videos was indeed empty - but now I could set it and voila :)

comment:11 Changed 10 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed

Thanks for reporting back.

Note: See TracTickets for help on using tickets.