Opened 10 years ago

Closed 10 years ago

#7846 closed defect (worksforme)

VDPAU + live TV ...image shifts down-right by 1 pixel each channel change

Reported by: Ronald Frazier <ron@…> Owned by: markk
Priority: minor Milestone: 0.23
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When watching Live TV on VDPAU cards using a VDPAU profile, the image shifts down/right by 1 pixel per channel change. On some TVs you don't notice this until you've changed channels 30 or more times (due to overscan). On my aquos you see it right away. There is a single pixel line at the top and left of the screen. Everytime you change the channel, the image shifts downright and the line at the top and left gets 1 pixel larger. The problem does not occur if I switch to a non-VDPAU profile. It does not occur on prerecorded content or when playing videos. Changing the theme or OSD doesn't help either.

I'm running 0.22 fixes with the 190.53 drivers on a G210 card.

Attachments (1)

sample.log (232.9 KB) - added by Ronald Frazier <ron@…> 10 years ago.
-v playback log with 4 channel changes

Download all attachments as: .zip

Change History (3)

comment:1 Changed 10 years ago by markk

Milestone: unknown0.23
Owner: changed from Janne Grunau to markk
Status: newaccepted

Ron - can you please attach a -v playback log. thnks, Mark

Changed 10 years ago by Ronald Frazier <ron@…>

Attachment: sample.log added

-v playback log with 4 channel changes

comment:2 Changed 10 years ago by markk

Resolution: worksforme
Status: acceptedclosed

I can't reproduce this with a variety of settings on 2 different frontends with trunk. If there was an issue it may have been resolved with the newer VDPAU code.

Note: See TracTickets for help on using tickets.