Opened 10 years ago

Closed 10 years ago

#7984 closed defect (fixed)

Commercial break detection on H264 progressive recordings off by 2

Reported by: Robin Gilks <g8ecj@…> Owned by: cpinkham
Priority: minor Milestone: 0.23
Component: MythTV - Mythcommflag Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Commercial detection on local FTA H264 720p transmissions seems to find commercials but they all seem to be exactly half the length expected (expected 4minutes, skip is 2 minutes).

Maybe related, editing/importing breaks of one of these programs results in all commercials to be in the first half of the recording only but the expected number of breaks appears to be correct - i.e. another off by 2 error.

Not sure how to present more info as the files are about 4gigs per hour.

MythTV Version : 23167 MythTV Branch : branches/release-0-22-fixes Network Protocol : 50 Library API : 0.22.20091023-1 QT Version : 4.5.3 Options compiled in:

linux release using_oss using_alsa using_jack using_backend using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Change History (5)

comment:1 Changed 10 years ago by cpinkham

Can you please provide a sample clip that I could download somewhere? I just need a short clip that includes a commercial break and a short segment before and after.

comment:2 Changed 10 years ago by robertm

Status: newinfoneeded_new

See above request. If you want to see this fixed for .23, sooner is better.

comment:3 Changed 10 years ago by Robin Gilks <g8ecj@…>

Clip already supplied offlist to Chris a month ago...

comment:4 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:5 Changed 10 years ago by cpinkham

Resolution: fixed
Status: newclosed

This frame count issue does not occur in trunk on the sample video provided by the submitter, it is possible that this was fixed by the libavcodec resync or one of the other fixes along the way. I'm closing this ticket for now. It can be reopened if someone can reproduce with current trunk.

Note: See TracTickets for help on using tickets.