Opened 9 years ago

Closed 9 years ago

#8054 closed patch (fixed)

Error exporting XviD through nuvexport using mencoder for singe pass with no quantisation

Reported by: misterhaan <mythtv@…> Owned by: beirdo
Priority: minor Milestone: unknown
Component: Apps - Nuvexport Version: 0.22
Severity: medium Keywords: nuvexport mencoder xvid
Cc: Ticket locked: no

Description

In an attempt to speed up running nuvexport on HD recordings, I changed my settings to single pass with constant bitrate (not defining quantisation). When I ran nuvexport manually to test this out, it failed immediately. Debug mode gave me the commands which I ran individually. All was well except for the mencoder command which quit immediately with an error about bitrate not being an option. I don't remember the actual error but I do know what the problem is: it adds :bitrate=$self->{'v_bitrate'} to the -lameopts value instead of specifying -xvidencopts.

I looked at XviD.pm in SVN and you can see the problem on line 160. Prior to the if/else statement it adds -oac mp3lame -lameopts vbr=3:br=$self->{'a_bitrate'} to mencoder_xtra, then since quantisation isn't set it falls through to the bitrate case on line 160, but instead of setting -xvidencopts it ends up adding bitrate to the lameopts. I was able to fix it on my machine by changing ":bitrate= to " -xvidencopts bitrate= on line 160. I don't know how to create a patch so will attach the full XviD.pm with my change.

Attachments (1)

XviD.pm (6.7 KB) - added by misterhaan <mythtv@…> 9 years ago.
Updated XviD.pm with the problem fixed.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by misterhaan <mythtv@…>

Attachment: XviD.pm added

Updated XviD.pm with the problem fixed.

comment:1 Changed 9 years ago by beirdo

Owner: changed from xris to beirdo
Status: newassigned

comment:2 Changed 9 years ago by beirdo

Resolution: fixed
Status: assignedclosed

(In [23573]) Incorporated provided fix for single pass with no quantization enabled. Closes #8054

Note: See TracTickets for help on using tickets.