Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8098 closed defect (fixed)

Aspect Ratio not correct in .m4v anamorphic videos

Reported by: Britney Fransen <britney.fransen@…> Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since the ffmpeg sync .m4v h.264 anamorphic videos do not show in the correct aspect ratio. This worked correctly in 23457 but not in 23578. The videos were encoded using Handbrake. Videos encoded with the same settings but to a .mkv container playback correctly both before the ffmpeg sync and after.

Here is a sample anamorphic .m4v: http://iw.net/~brfransen/myth/anamorphic.m4v

Change History (7)

comment:1 Changed 10 years ago by robertm

Milestone: 0.23unknown

comment:2 Changed 10 years ago by mythtv@…

Just in case it is of any help: the aspect ratio correction looks to be being applied twice. 720x576 movies intended for playback in 1024x576 end up looking more like typical film aspect ratios.

comment:3 Changed 10 years ago by markk

Can you clarify what aspect ratio the video should be displayed at?

thanks, Mark

comment:4 Changed 10 years ago by Britney Fransen <britney.fransen@…>

Mark, the sample video should be displayed as 1.78:1.

comment:5 Changed 10 years ago by markk

Resolution: fixed
Status: newclosed

(In [24976]) Prefer the video aspect ratio provided by the context over that provided by the stream. Fixes #8098.

I've tested extensively here and can see no regressions.

comment:6 Changed 10 years ago by anonymous

Brilliant! Thanks Mark. Is this the sort of thing that would also go on the fixes branch?

comment:7 in reply to:  6 Changed 10 years ago by anonymous

Replying to anonymous:

Brilliant! Thanks Mark. Is this the sort of thing that would also go on the fixes branch?

Please keep such comments on the mailing list.

Note: See TracTickets for help on using tickets.