Opened 9 years ago

Closed 9 years ago

#8232 closed defect (wontfix)

Error in OSD prevents relative seek and channel change

Reported by: Matt White <whitem@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords: osd, seek, channel
Cc: Ticket locked: no

Description

I updated my main machine last night to 0.23-fixes to do some more testing. Everything went very smoothly (very nice work, developers).

I grabbed the theme contest entry themes, so I could have a look at them and vote.

This morning, I was watching a recorded curling game from last night, and wanted to skip ahead - I do this all the time (press 5 then right, presto 5 minutes ahead). It didn't work...

So, I searched the mailing lists. I found Mike Dean's great explanation of his changes to sticky keys, SEEKFWD, FWDSTICKY, etc (subject "Seek (back and forth) broken in MythTV trunk r23186"). I do use sticky keys, so I went back again and made sure that the changes to my key bindings had been done correctly (it was). Still couldn't do relative seeks.

As I woke up (hey, I'm not seriously conscious before noon), I noticed that the numbers were not even being displayed by the OSD when I typed them in before I hit "right". So, I went trolling through the source to find out what had changed. I couldn't find anything useful.

With logging cranked up, the only thing that happened when I pressed a number key while playing a recording was:

TV: CommitQueuedInput?() livetv(0) qchannum(1) qchanid(0)

TV: CommitQueuedInput?() livetv(0) qchannum(2) qchanid(0)

I pressed "1", then "2" there.

I started this ticket, and decided I'd check liveTV (don't use it much) to see if numbers showed up for changing channels. They didn't (and I couldn't type in a channel and change to it), but I remembered that I had tested channel changing immediately after upgrading and it worked. When I cranked logging up again, typing "1" then "2" again during playback now gave me:

TV: CommitQueuedInput?() livetv(0) qchannum(1) qchanid(0)

TV: CommitQueuedInput?() livetv(0) qchannum(12) qchanid(0)

Long story short, I had chosen the OSD from the submitted "TransBlue?" theme as my Playback OSD. I went and changed the OSD back to something else (blueosd, but others worked the same). Suddenly, I can do relative seeks, I can do channel changes, everything works! Somehow, something in the OSD setup for "TransBlue?" seems to interact with Myth in a way to disable functionality.

I'm completely clueless on themes, but I'll continue trying to figure this out - I wanted to submit this report because it is entirely likely that someone more familiar with that area of the code will be able to quickly solve the problem.

Change History (1)

comment:1 Changed 9 years ago by robertm

Resolution: wontfix
Status: newclosed

Matt,

I appreciate the troubleshoot that you've done. It appears to me that the issue is a OSD theme bug, and one for which we have no control-- worth bearing in mind when voting on themes, but not (as far as I can tell) a Myth bug.

Note: See TracTickets for help on using tickets.