Opened 9 years ago

Closed 8 years ago

#8290 closed defect (Fixed)

DVD: internal player exits on menu transition

Reported by: linux@… Owned by: skamithi
Priority: minor Milestone: 0.24
Component: MythTV - DVD Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

I have some DVDs for which the internal DVD player exits right after the movie studio logo sequence at the beginning of the DVD instead of proceeding to the DVD menu. I started seeing this problem with 0.22 while in in 0.21 it was not present. Jumping directly to the menu during that sequence is a workaround for the problem.

I did some debugging and the problem is that in AvFormatDecoder::GetFrame the call of av_read_frame(ic, pkt) in line 3669 returns -1 while the transition to the DVD menu is in progress which makes the player exit:

            if (!ic || (av_read_frame(ic, pkt) < 0))
            {
                ateof = true;
                GetNVP()->SetEof();
                delete pkt;
                return false;
            }

Ignoring the return code solves the problem, but hardly looks like the proper fix to me.

I am attaching the log of a '-v playback,extra' run to this ticket, and am running the release-0-23-fixes branch at 23952.

Thanks and best wishes,

Martin.

Attachments (1)

mythfrontend.log (22.5 KB) - added by Martin Kittel <linux@…> 9 years ago.
mythfrontend log of player run that exits prematurely

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Martin Kittel <linux@…>

Attachment: mythfrontend.log added

mythfrontend log of player run that exits prematurely

comment:1 Changed 9 years ago by skamithi

Status: newinfoneeded_new

can you test the dvd using the trunk version and report your findings.

comment:2 Changed 9 years ago by linux@…

I checked with trunk revision 24003 and the problem shows there as well.

Best wishes,

Martin.

comment:3 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:4 Changed 9 years ago by robertm

Status: newinfoneeded_new

Martin,

Please check with current trunk if possible, much of the video output stuff has been rewritten and it would be nice to have updated results.

comment:5 Changed 9 years ago by linux@…

Unfortunately the problem still persists. Even worse, for one of the problematic iso images now even the workaround of jumping directly to the menus does not work any more. One thing I noticed is that the aspect ratio was already changing to the 16:9 aspect of the menus after the 4:3 aspect studio intro when the player exited. Please let me know if you need special trace logs. I am sorry but I currently do not have the time to look deeper into where exactly the problem is happening now. I have been checking with trunk version 25532.

Best wishes,

Martin.

comment:6 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:7 Changed 9 years ago by robertm

Status: newassigned

comment:8 in reply to:  7 Changed 8 years ago by linux@…

Replying to robertm:

Hi,

I have tested again with release 0.24 and could not reproduce the problem any more. Unfortunately I do no have the time to check which commit actually fixed the problem. I just hope it's not a timing related effect that just doesn't show any more.

Best wishes,

Martin.

comment:9 Changed 8 years ago by robertm

Milestone: unknown0.24
Resolution: Fixed
Status: assignedclosed

We'll take it. ;) Thanks for reporting back.

Note: See TracTickets for help on using tickets.