Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 2 years ago

#8316 closed Bug Report - General (fixed)

MythTV Playlist exits prematurely

Reported by: Ryan Hadley <ryan.hadley@…> Owned by: stuartm
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

When I add a good amount (10+) of videos to a playlist and start it up, it never plays through the entire list. It appears to be random where it exits. I can play the same playlist several times and it will always exit the playlist and return me to the recorded programs menu before it gets to the end of the playlist.

If I add just a few, 2-3 shows, it sometimes plays the whole list. But occasionally will even exit out after the first show is done.

I'm running off head from just last night (4/7/2010).

# mythfrontend --version
Please include all output in bug reports.
MythTV Version : 23989
MythTV Branch : trunk
Network Protocol : 56
Library API : 0.23.20100404-1
QT Version : 4.5.0
Options compiled in:

linux release using_oss using_alsa using_backend using_directfb using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

# mythbackend --version
Please include all output in bug reports.
MythTV Version : 23989
MythTV Branch : trunk
Network Protocol : 56
Library API : 0.23.20100404-1
QT Version : 4.5.0
Options compiled in:

linux release using_oss using_alsa using_backend using_directfb using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

MythTV configure: ./configure --prefix=/usr/local/mythtv --enable-libfaad --enable-proc-opt --disable-lirc --disable-joystick-menu --enable-vdpau --extra-cflags=-fomit-frame-pointer --extra-cxxflags=-fomit-frame-pointer

Attachments (2)

mythfrontend_playlist_issue.log.gz (17.6 KB) - added by Ryan Hadley <ryan.hadley@…> 4 years ago.
mythfrontend.log (26.2 KB) - added by sa_upton@… 3 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 4 years ago by robertm

  • Status changed from new to infoneeded_new

Need -v playback frontend logs.

Changed 4 years ago by Ryan Hadley <ryan.hadley@…>

comment:2 Changed 4 years ago by Ryan Hadley <ryan.hadley@…>

Added 13 shows to playlist. Played playlist on shuffle mode. It played 2 shows and exited. I grabbed the log immediately after the playlist ended prematurely.

comment:3 Changed 4 years ago by robertm

  • Status changed from infoneeded_new to new

comment:4 Changed 4 years ago by robertm

  • Component changed from MythTV - General to MythTV - Video Playback
  • Owner changed from ijr to janne

comment:5 Changed 4 years ago by scooter <mythtv@…>

I'm not sure if it is frowned upon for this type of "me too" message, but....

If a different system is needed for debugging, I can assist.
I'm also experiencing the problem described in this issue.
Dedicated backend system and multiple frontends on 0.23.

One frontend and the backend at:
MythTV Version : 25141
MythTV Branch : branches/release-0-23-fixes/mythtv/
Network Protocol : 56
Library API : 0.23.201000617-1
QT Version : 4.6.2

And one frontend at:
MythTV Version : Unknown
MythTV Branch : branches/release-0-23-fixes
Network Protocol : 56
Library API : 0.23.20100429-1
(latest minimyth 0.23 release)

Scott

comment:6 Changed 4 years ago by robertm

  • Status changed from new to assigned

comment:7 Changed 4 years ago by jra@…

We're seeing this as well, 0.23.1 from RPM on SuSE 11.3. Initially I thought it might be related to MythTV locating clips in a storage group that it hadn't yet played and caching their locations (we imported our old programs into a fresh install), but we ruled that out.
Does the assignee want -v playback logs from us as well?

comment:8 Changed 3 years ago by matthyo@…

any news on this? happens to me too in 0.24 and 0.24-fixes, it does appear to be random but I am rarely ever able to play 2 or 3 things in a row, If I remember to hit 'Esc' before the recording ends it will play the next recording like it is suppose to.

I'd really like to set a bunch of stuff to watch rather than always choosing something every 30/60 mins, I've even tried switching over too Xbmc but that just has a whole bunch more bugs.

comment:9 Changed 3 years ago by robertm

  • Ticket locked set

Changed 3 years ago by sa_upton@…

comment:10 Changed 2 years ago by cpinkham

  • Owner changed from janne to cpinkham

comment:11 Changed 2 years ago by stuartm

  • Milestone changed from unknown to 0.25
  • Type changed from defect to Bug Report - General
  • Version changed from head to Master Head

This doesn't look that complicated to figure out, I'm willing to bet it's the 100ms timeout on the availability check - when that's reached we clear the whole playlist. 100ms seems far too short if we're having to spin up a drive or similar to check the file is available.

comment:12 Changed 2 years ago by stuartm

  • Owner changed from cpinkham to stuartm
  • Status changed from assigned to accepted

comment:13 Changed 2 years ago by Github

  • Resolution set to fixed
  • Status changed from accepted to closed

Increase kMaxUIWaitTime to 10 seconds. The theory is that this timeout was to prevent a very delayed response to an availability check causing playlists to resume playing long after the user had moved on. The present timeout was very short though and didn't account for delays caused by disks needing to be spun up or just the latency of checking multiple storage groups for a file. Almost certainly fixes #8316

Branch: master
Changeset: 6c3a799706eb6f18757f8984819bf5c4c2425659

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.