Opened 10 years ago

Closed 10 years ago

#8378 closed patch (duplicate)

Sound off by ~200ms (at least with pulse audio)

Reported by: Marc Randolph <mrand@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.23rc2
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Forwarding upstream. I user has verified that [24214] indeed fixed the major pulse audio seeking problem when applied against to the 0.23-fixes branch. He did notice sound sync was off by a bit though, and found that the following patch fixes it:

Index: libs/libmyth/audiooutputpulse.cpp
===================================================================
--- libs/libmyth/audiooutputpulse.cpp	(revision 24255)
+++ libs/libmyth/audiooutputpulse.cpp	(working copy)
@@ -564,7 +564,7 @@
     fragment_size = 20UL * sample_rate * audio_bits * audio_channels
         / 8 /* 8 bits per byte */ / 1000 /* 1000 ms per second */;
 
-    soundcard_buffer_size = 16 * fragment_size;
+    soundcard_buffer_size = 6 * fragment_size;
     buffer_settings.maxlength = soundcard_buffer_size;
     buffer_settings.tlength = fragment_size * 4;
     buffer_settings.prebuf = (uint32_t)-1;

Change History (1)

comment:1 Changed 10 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #7496.

In short, PulseAudio? is not expected to be in sync.

Note: See TracTickets for help on using tickets.