Opened 10 years ago

Closed 10 years ago

#8416 closed patch (fixed)

[PATCH] mythtv.org index page doesn't rendor correctly in IE8

Reported by: skd5aner <skd5aner@…> Owned by: xris
Priority: trivial Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: low Keywords: website
Cc: Ticket locked: no

Description

IE8 does not render www.mythtv.org correcty due to legacy IE hacks, picture showing the issue here: http://i42.tinypic.com/2e5qt5f.jpg http://i42.tinypic.com/2e5qt5f.jpg

Simple fix below, which allows the main mythtv.org page to render correctly in IE8 using the standard CSS like the rest of the browsers. (No more custom CSS needed for IE8+). Reproduced the source locally, and tested to ensure this would give the results desired.

Change line 7 in index.html from:

    <!--[if IE]><link rel="stylesheet" type="text/css" href="/css/ie.css" ><![endif]-->

to

    <!--[if lt IE 8]><link rel="stylesheet" type="text/css" href="/css/ie.css" ><![endif]-->

Details:
In previous version of Internet Explorer (<8), certain conditional css elements needed to be given in order for IE6 and IE7 to render as expected. However, IE8 is greatly improved in terms of correctly rendering CSS and in general being a more standards compliant browser.

The issue is that the main index.html page of the site currently utilizes conditional comments for anything less than or equal to IE6, or anything equal to IE (every version). IE8 captures this conditional comment, and rendors the CSS which is intended for IE7 and below, causing the page to rendor incorrectly. A user can work around this by putting IE8 into IE7 compatibility mode, but that's really taking a step backward and isn't a viable solution.

By simply telling the hack to apply to any IE products that register < IE8, anyone using the legacy browsers should continue to function exactly as they are today. However, IE8+ users will not leverage the hacks, and will use whatever is in the standard CSS files - allowing for a standard CSS format across all standard compliant browsers from here forward, and for correct rendoring of the page.

Change History (2)

comment:1 Changed 10 years ago by robertm

Owner: changed from Isaac Richards to xris
Priority: minortrivial
Severity: mediumlow
Status: newassigned

Not normally what we track in trac, an e-mail to the dev list might be more expedient in the future.

comment:2 Changed 10 years ago by xris

Resolution: fixed
Status: assignedclosed

It'll go out with the next push (not sure when that'll be, there are some other pending fixes that need more work).

Note: See TracTickets for help on using tickets.