Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8487 closed defect (fixed)

Never Record sometimes fails on MythWeb

Reported by: Doug Haber <doug@…> Owned by: Rob Smith
Priority: minor Milestone: 0.24
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

I have two back-to-back scheduled recordings (8pm and 9pm). When I click "Never Record" on the Upcoming Recordings page for the first one, the schedule updates properly. However, when I click "Never Record" for the second one, the schedule is not updated (instead a Never Record row is inserted into the oldrecordings table for the first one). If I use MythFrontend instead, everything works.

I did some research and I found the following:

The url for Never Record is something like: /mythweb/tv/upcoming/<chanid>/<starttime>?never_record=yes and the chan id and starttime are always correct. This hits modules/tv/upcoming.php loads the program and calls $program->rec_never_record at line ~40. The problem is at this point $program is pointing to the wrong program (8pm not 9pm). $program is loaded via load_one_program from tv/includes/programs.php which in turn calls load_all_program_data. load_all_program data correctly looks up the chanid & starttime, however, it compares this data to the data in the $Scheduled_Recordings array around line ~193. Here it incorrectly finds a match, gets confused and uses the 8pm show instead of the 9pm show. The data appears to get incorrectly loaded into the Scheduled_Recordings array in tv/includes/recording_schedules.php around line 84. For some reason the foreach loop returns the starttime for the 8pm show as if it were at 9pm. I'm not sure why that happens, but because it finds the wrong starttime, the values gets messed up and (eventually) "Never Record" inserts a row for the wrong program.

Thanks[[BR]] Doug

Change History (4)

comment:1 Changed 9 years ago by doug@…

I bet this was fixed by 24808. I'll svn up and check tomorrow.

Thanks!

D

comment:2 Changed 9 years ago by Doug Haber <doug@…>

Yup - [24808] did the trick

Thanks!

D

comment:3 Changed 9 years ago by sphery

Resolution: fixed
Status: newclosed

Fixed in [24808]. Thanks for reporting back, Doug.

comment:4 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.