Opened 9 years ago

Closed 9 years ago

#8499 closed defect (wontfix)

Audio comes out wrong channel

Reported by: natenate@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: 0.23rc2
Severity: low Keywords:
Cc: Ticket locked: no

Description

In 5.1 mode the audio for the front center was coming out the rear speaker when I was using Pulse:default as the output device.

I set EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1 and switched to ALSA:default and the sound came out the correct speaker.

Sound works correctly in VLC and using speaker-test.

Attachments (1)

version_info (698 bytes) - added by Raymond Wagner 9 years ago.
moved version info to file

Download all attachments as: .zip

Change History (3)

comment:1 Changed 9 years ago by Raymond Wagner

Status: newinfoneeded_new

You have not specified the version this is against. Please indicate branch and revision.

Changed 9 years ago by Raymond Wagner

Attachment: version_info added

moved version info to file

comment:2 Changed 9 years ago by Raymond Wagner

Resolution: wontfix
Status: infoneeded_newclosed
Version: Unspecified0.23rc2

Revision 24158 is a pre-release version of 0.23. The official release of 0.23 was not until revision 24521. Please update your install to a more recent version.

0.23 does not officially support Pulseaudio as an output method. For normal use, mythfrontend will disable Pulseaudio, and attempt to access the ALSA system beneath directly. Proper support for Pulseaudio was committed to trunk several weeks ago, and will be available in 0.24.

I'm closing this for now. If the same behavior exists in trunk, or 0.24 when it is released, it can be re-opened.

Note: See TracTickets for help on using tickets.