Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8502 closed defect (duplicate)

segfault in libmythtv-0.23.so.0.23.0

Reported by: blammo@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.23-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

ran into a "crash-to-desktop" issue while watching an episode of CSI tonight. repeatable.. same spot every time, crash to desktop.

Fortunately, it's in the first 30 seconds of the recording, so I can FTP it.

attached is also "mythfrontend -v most"

running mythdora 12.x with fixes:

Please attach all output as a file in bug reports. MythTV Version : 0.23-1.md12 (r24509) MythTV Branch : tags/release-0-23 Network Protocol : 56 Library API : 0.23.20100429-1 QT Version : 4.6.2 Options compiled in:

linux release using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Attachments (1)

frontend.crash.log.8502.zip (38.5 KB) - added by blammo@… 10 years ago.
mythfrontend -v most - up to point of crash

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by blammo@…

Attachment: frontend.crash.log.8502.zip added

mythfrontend -v most - up to point of crash

comment:1 Changed 10 years ago by robertm

Milestone: 0.23-fixesunknown
Priority: majorminor
Severity: mediumlow
Status: newinfoneeded_new

We need a backtrace as per the manual and ideally a sample that exhibits the issue.

http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Also, please read the ticket howto. Do not set priority or milestone.

comment:2 Changed 10 years ago by blammo@…

I can give you the sample -- the first 30 seconds is 57Megs.. where would you like it?

comment:3 Changed 10 years ago by robertm

anywhere you like is fine. Do please provide the backtrace as well.

comment:4 Changed 10 years ago by blammo@…

RobertM, please send me an email, I'll respond with download location.

comment:5 Changed 10 years ago by anonymous

had a friend put it up in a temp location - let me know when you have it downloaded.

http://64.146.64.164/first.30seconds.crash.8502.mpg.zip

comment:6 Changed 10 years ago by stuartm

Component: MythTV - GeneralMythTV - Video Playback

The sample doesn't cause a crash here with either VDPAU or ffmpeg. We'll probably need a backtrace and more details. Which playback profile are you using? 32bit or 64bit?

N.B. You're not on the -fixes branch

comment:7 Changed 10 years ago by james.vanmetre@…

I am running into the same problem with both the 32 and 64 bit versions of mythfrontend. uname -a Linux myth-dell 2.6.32.12-115.fc12.i686 #1 SMP Fri Apr 30 20:34:53 UTC 2010 i686 i686 i386 GNU/Linux

Pertinent rpm names are mythtv-backend-0.23-1.fc12.i686 mythtv-common-0.23-1.fc12.i686 mythtv-0.23-1.fc12.i686 mythtv-themes-0.23-1.fc12.noarch mythtv-debuginfo-0.23-1.fc12.i686 mythtv-frontend-0.23-1.fc12.i686 mythtv-libs-0.23-1.fc12.i686

I have uploaded a sample that crashes around the 24 second point here: http://rapidshare.com/files/392636175/crash_around_24_seconds.8502.mpg.html

And the gdb.txt of the crash is here: http://pastebin.com/qdfAdH27 -James

comment:8 Changed 10 years ago by stuartm

Resolution: duplicate
Status: infoneeded_newclosed

Hmm, you are both using 0.23.0 (not 0.23-fixes) with Fedora. Can you both upgrade to the latest version of 0.23-fixes and see if that helps?

At least one crash in AVFormatDecoder was fixed after the 0.23 release and the behaviour I'm seeing with trunk suggests that fix addresses the crash you are reporting. With trunk it doesn't crash @24 seconds, instead there is a temporary glitch consistent with a change in the stream. This was fixed in [24606]

Closing as a duplicate of #8445 which was fixed in [24606]

comment:9 Changed 10 years ago by blammo@…

stuartm -- I realized that the process I used to snip the 30 seconds, ffmpeg, cleaned up the problem in the file.. the 30 second snip doesn't kill the player, but the full video did.. Any suggestions for a "clean" way to snip the first 30 seconds that doesn't re-encode?

comment:10 Changed 10 years ago by robertm

dd if=infile of=outfile bs=1024k count=50

will produce 50 MB...

But we don't need a sample until you have upgraded to current fixes (which you are not running) and reproduced this issue.

comment:11 Changed 10 years ago by anonymous

sadly, I already deleted the original, thinking I had snipped safely.. :( Thank you for the command, I'll use it next time.

comment:12 Changed 10 years ago by james.vanmetre@…

I removed all of the rpm packages for mythtv and installed .23-fixes like you suggested and that did indeed fix the problem.

Note: See TracTickets for help on using tickets.