Opened 9 years ago

Closed 9 years ago

#8554 closed defect (invalid)

Auto Zoom/Fill (letterbox detection) does not work with VDPAU

Reported by: anonymous Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.23-fixes
Severity: medium Keywords: detectletterbox zoom vdpau
Cc: Ticket locked: yes

Description

When VDPAU is being used, letterbox detection does not work.

It looks like there was some unfinished support for VDPAU in the attachment detectLetterboxV9.patch on bug #4872.

Change History (3)

comment:1 Changed 9 years ago by markk

Resolution: invalid
Status: newclosed

Letterbox detection does not work with VDPAU because the code, as currently written, only works with video frames in main memory.

If you want it to work with VDPAU, you'll need to write the code to transfer the decoded frames from GPU memory back to main memory for analysis.

comment:2 Changed 9 years ago by ian@…

Resolution: invalid
Status: closednew

This is still a bug as it is unexpected behavior, regardless of implementation details. Perhaps it can be 'fixed' by stating that zoom auto-detect is unsupported with VDPAU on the settings screen.

comment:3 Changed 9 years ago by robertm

Resolution: invalid
Status: newclosed
Ticket locked: set
Note: See TracTickets for help on using tickets.