Opened 9 years ago

Closed 9 years ago

#8633 closed defect (duplicate)

OSD merge broke Mac playback

Reported by: Nigel Owned by: markk
Priority: minor Milestone: 0.24
Component: Ports - OSX Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Merge from mythui-osd branch, [24972] (plus trivial compile fix [25028]), broke playback on OS X:

./mythfrontend -v playback
2010-07-02 20:55:53.953 mythfrontend version: trunk [24972M] www.mythtv.org
...
2010-07-02 20:59:45.017 AFD: HandleGopStart: Key frame distance changed from 7 to 12.
2010-07-02 20:59:45.059 NVP(0): Enabled deinterlacing
2010-07-02 20:59:45.075 VideoOutput: Created YV12 OSD.
2010-07-02 20:59:45.450 NVP(0): Video is 4.09218 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:45.502 NVP(0): Video is 5.93162 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:45.550 NVP(0): Video is 7.4237 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:45.598 NVP(0): Video is 8.58027 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:45.647 NVP(0): Video is 9.49145 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:45.715 NVP(0): Video is 10.2123 frames behind audio (too slow), dropping frame to catch up.
...
2010-07-02 20:59:48.372 NVP(0): Video is 29.5329 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:48.419 NVP(0): Video is 29.7997 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:48.488 NVP(0): Video is 30 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:48.560 NVP(0): Video is 30 frames behind audio (too slow), dropping frame to catch up.
2010-07-02 20:59:48.609 NVP(0): Video is 30 frames behind audio (too slow), dropping frame to catch up.

ad infinitum.
The first frame of the video is happily displayed. Pressing P repeatedly gives occasionally updating static images, punctuated with:

2010-07-02 21:04:52.364 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_PAUSED HOSTNAME MacBook.local CHANID 1000 STARTTIME 2000-06-16T01:00:00 SENDER MacBook.local) called from UI thread
2010-07-02 21:04:52.390 OSD_ERR: Failed to create window osd_status
2010-07-02 21:04:52.390 OSD_ERR: Failed to create window osd_status
2010-07-02 21:04:52.431 NVP(0): Play speed: rate: 25 speed: 0 skip: 0 => new interval 0
2010-07-02 21:04:52.431 SetVideoFrameRate(0) - unimplemented?
2010-07-02 21:04:52.431 Set video sync frame interval to 0
2010-07-02 21:04:52.508 NVP(0): Play(  1.0, normal 1, unpause audio 1)
2010-07-02 21:04:52.509 NVP(0): Play speed: rate: 25 speed: 1 skip: 1 => new interval 40000
2010-07-02 21:04:52.509 SetVideoFrameRate(25) - unimplemented?
2010-07-02 21:04:52.509 Set video sync frame interval to 40000
2010-07-02 21:04:52.509 NVP(0): Stretch Factor 1, allow passthru 

I'll trace the OSD window error thru, but am at a loss as to what in #7650 has affected quartz-blit playback :-(

Change History (1)

comment:1 Changed 9 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #8630

Appears to be a QT bug.

Note: See TracTickets for help on using tickets.