Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 4 years ago

Last modified 20 months ago

#8643 closed patch (fixed)

patch for DLNA capable Samsung TV-s

Reported by: banogabor@… Owned by: beirdo
Priority: minor Milestone: 0.24
Component: MythTV - UPnP Version: Master Head
Severity: medium Keywords: samsung dlna
Cc: Ticket locked: yes

Description

Hi! This patch fixes two problems, when you try to play movies on DLNA capable Samsung TV ( tested on my own LE37B650 )

1, With the TV restricted software ( PC share manager ) detects and plays correctly the 'mkv' type files. Because this TV doesn't recognize the 'video/x-matroska' MIME type, therefore must change it to 'video/x-mkv' to plays it.

  1. When plays any video on TV ( except recorded programs ) cannot pause its. The TV doesn't accept videos with zero duration. I'm set it to one minute, what isn't correct indeed, but able to pauses anywhere the videos. Unfortunatelly isn't any correct movie file duration detect method yet, therefore this parameter is a constant.

Is there anyone, who sends me a full DLNA document link?

Attachments (1)

samsung-dlna-patch.diff (1.2 KB) - added by banogabor@… 4 years ago.
patch for samsung dlna TVs

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by banogabor@…

patch for samsung dlna TVs

comment:1 Changed 4 years ago by stuarta

  • Owner changed from dblain to beirdo
  • Status changed from new to assigned

Beirdo, since you were looking at stuff exactly like this
last night you can have it :)

Stuart

comment:2 follow-up: Changed 4 years ago by beirdo

For the first part of the patch: Are we sure this will not cause a regression for other UPnP/DLNA players? I'll look into the code to see the heritage of that commit.

comment:3 Changed 4 years ago by beirdo

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [25300]) Changed matroska video MIME type to video/x-mkv and tweaked the reported
duration of videos (not recordings) to 1 min. These tweaks to the UPnP are
reported to make it work better with Samsung TVs, and we don't know of any
regressions.

Closes #8643

comment:4 in reply to: ↑ 2 Changed 4 years ago by anonymous

Replying to beirdo:

For the first part of the patch: Are we sure this will not cause a regression for other UPnP/DLNA players?

I don't know. My DLNA TV doesn't recognize x-matroska type, therefore rejects mkv's as unknown, but the official manual contains the mkv support and it works with its own software.
Because I haven't got the (official) DLNA standards, I don't know where search the solution:

May be in the samsung firmware contains this mistake, but while haven't got description, I have no evidence to this. So don't construe to complain it at samsung.

Well now, currently simpliest to change MIME type to x-mkv in mythtv source to enable mkv's playing on TV. Some more test need to clear up, to know is this patch causes any problem in other players.

I'll look into the code to see the heritage of that commit.

Not sure.

comment:5 Changed 4 years ago by beirdo

  • Ticket locked set

This was committed into trunk 5 days ago.

comment:6 Changed 4 years ago by stuartm

  • Milestone changed from unknown to 0.24

comment:7 Changed 20 months ago by Raymond Wagner <rwagner@…>

In 749ac86220f72887be1e3cb0fb2d84979ae639ef/mythtv:

Revert Matroska MIME to 'video/x-matroska'.

If different clients are expecting different MIME times, the only
sensible solution is to use the one dictated by Matroska.

http://matroska.org/technical/specs/notes.html#MIME
Refs #8643
Fixes #10980

comment:8 Changed 20 months ago by Raymond Wagner <rwagner@…>

In cf06841da2364878ca7f4eff0240f9c470e841da/mythtv:

Revert Matroska MIME to 'video/x-matroska'.

If different clients are expecting different MIME times, the only
sensible solution is to use the one dictated by Matroska.

http://matroska.org/technical/specs/notes.html#MIME
Refs #8643
Fixes #10980
(cherry picked from commit 749ac86220f72887be1e3cb0fb2d84979ae639ef)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.