Opened 9 years ago

Closed 9 years ago

#8659 closed defect (worksforme)

AC3 drops to 2 channels for rest of program

Reported by: Dave Badia <dbadia@…> Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Upgraded to 23-fixes 25298 over the weekend, and I’ve noticed some audio differences from .22. I’ve always had some hiccups in the audio from my hdpvr recordings and with .22 these manifest themselves as the audio dropping out for about a sec, then resuming (with 5.1). However, with .23 fixes it seems the audio drops from 5.1 to 2 channels but never goes back to 5.1. If I restart playback at that point, 5.1 audio resumes. Enabled verbose audio and did some research. I think what’s happening is the audio is switching from 6 to 2 channels, then back from 2 to 6, but Fix #8030 is causing the switch back to be ignored as it occurs within 30 frames. To test my theory I set #define AUDIOMAXFRAMES to 0 and, low and behold, the audio now resumes back to 5.1 as expected. I’m really not sure what the proper fix would be, as I don’t know the background of Fix #8030. I find the behavior in .22 (1 sec audio drop) preferable to the current .23-fixes behavior, as the drop to 2 channel results in a major drop in loudness which causes the user to have to increase the volume, only to get blow away when a new recording is started with 5.1. I've attached some of my log file. I can provide part of the recording if it’s helpful.

Attachments (1)

audio.log (2.2 KB) - added by Dave Badia <dbadia@…> 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Dave Badia <dbadia@…>

Attachment: audio.log added

comment:1 Changed 9 years ago by robertm

Status: newassigned

comment:2 Changed 9 years ago by JYA

Resolution: worksforme
Status: assignedclosed

Update to trunk, this should be fixed. Re-opened if not.

Note: See TracTickets for help on using tickets.