Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8727 closed defect (worksforme)

DVB card setup: default timeouts shown in place of configured values

Reported by: Nick Morrott <knowledgejunkie (at) gmail (dot) com> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Mythtv-setup Version: Master Head
Severity: medium Keywords: dvb-t setup timeouts
Cc: Ticket locked: no

Description

Using the same configuration as reported in #8726.

When configuring a new DVB card, changing the signal/tuning timeouts before entering the Recording Options page results in the adjusted timeout values being replaced with the default values (1000ms/3000ms) when returning from the Recording Options page.

However, the user-specified values are stored in the database correctly, and the correct values are read/displayed if the card is re-edited after having navigated back to the capture card setup menu.

Change History (6)

comment:1 Changed 10 years ago by robertm

Owner: changed from Isaac Richards to danielk
Status: newassigned

Probably no use touching any of this, just to be closed in the rewrite.

comment:2 Changed 10 years ago by danielk

Resolution: worksforme
Status: assignedclosed

I can not reproduce with current trunk.

comment:3 Changed 10 years ago by Nick Morrott <knowledgejunkie <at> gmail <dot> com>

Tested on trunk @ r25642 and issue is still present.

For the record in case any else can duplicate this, I see the behaviour with the following steps:

i) Setup -> Capture Cards -> New Capture Card

ii) Set card type to DVB-T/S

iii) Modify signal and tuning timeouts

iv) Select "Recording Options"

v) Press "Finish" to return to the Capture Card Setup page

vi) the timeout values have reverted to their defaults.

If the timeouts are adjusted again, the values do stick after opening/closing the Recording Options page,.

comment:4 Changed 10 years ago by Nick Morrott <knowledgejunkie <at> gmail <dot> com>

This issue is still reproducible for me running trunk @ r26197 and configuring a DVB-T card in order to test patch on #8733.

comment:5 Changed 10 years ago by sphery

Nick, I think this is just another manifestation of the same bug that's causing the (first) issue mentioned on #6637. In other words, it's "just" a UI issue--the proper values are saved to the database, but they're not displayed properly when the page is re-loaded.

With the plan to replace the entire setup implementation--including all the UI code--chances are no one will make time to track down the issue and work out some solution for it. If someone does want to fix it, and comes up with a patch for the issues, we can put the fix in. If not, this one would probably fall under the same, "Not, strictly speaking, a dupe, but Ref #8262 since nobody is going to fix it, it's just going to get rewritten," as was used on #6637.

That said, we do appreciate all your testing and your motivation to help us improve MythTV.

comment:6 Changed 10 years ago by sphery

OK, after Raymond explained the focus of this ticket, it is a different issue (since it can't save anything into the database until the card is created and you've said it re-loads properly when going back to the page). So, in that case, it's a UI-unfriendliness feature until we rewrite the setup UI.

Note: See TracTickets for help on using tickets.