Opened 9 years ago

Closed 9 years ago

#8746 closed defect (Works for me)

Incorrect positioning of OSD

Reported by: otto at kolsi dot fi Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

OSD is incorrectly positioned (and scaled?) with some recordings. This probably is related to situation where video format changes e.g. when program starts. I've attached picture showing incorrect OSD positioning, log with "-v important,general,playback" and version information. Log file was produced by starting playback, skipping forward into actual recording (format has changed) and bringing up the OSD.

Grepping the log-file shows some interesting things. Interlace detection has wrong fps and resolution at some point:

2010-08-07 13:22:48.282 Player(0): detectInterlace(Detect Scan, Interlaced Scan, 25, 576) ->Interlaced Scan
2010-08-07 13:22:52.535 Player(0): detectInterlace(Detect Scan, Interlaced Scan, 29.97, 480) ->Interlaced Scan
2010-08-07 13:22:52.734 Player(0): detectInterlace(Detect Scan, Interlaced Scan, 25, 576) ->Interlaced Scan

OSD sizes:

2010-08-07 13:22:49.702 OSD: Loaded OSD: size 720x576 offset 0+0
2010-08-07 13:22:52.827 OSD: Loaded OSD: size 640x480 offset 0+0

Don't know if this is different issue, side-effect or totally harmless, kernel deint is being used instead of yadif 2x?

2010-08-07 13:22:49.826 VideoOutput: Using deinterlace method yadifdoubleprocessdeint
2010-08-07 13:22:52.488 VideoOutput: Using deinterlace method yadifdoubleprocessdeint
2010-08-07 13:22:52.541 VideoOutput: Using deinterlace method kerneldeint
2010-08-07 13:22:52.682 VideoOutput: Using deinterlace method yadifdoubleprocessdeint
2010-08-07 13:22:58.519 VideoOutput: Using deinterlace method kerneldeint

Attachments (3)

osd-incorrect-position.jpg (49.7 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-osd.log (36.2 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-version.txt (552 bytes) - added by otto at kolsi dot fi 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by otto at kolsi dot fi

Attachment: osd-incorrect-position.jpg added

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-osd.log added

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-version.txt added

comment:1 Changed 9 years ago by markk

Owner: changed from Janne Grunau to markk
Status: newaccepted

Can you try and upload a clip from that file that is long enough to skip in.

The root cause here is that the decoder fails to detect the size of the video stream:-

2010-08-07 13:22:52.357 VDP: LoadBestPreferences?(16x16, 60)

and falls back to some default values (640x480). After that things get a little messy for some reason. The decoder seems to pick up 720x576 again but not the framerate (hence the double rate deinterlacer fails) and then the OSD is still re-created at the wrong size.

comment:2 Changed 9 years ago by otto at kolsi dot fi

Thanks Mark for the explanation! I've uploaded 35M sample from the beginning of the program to: http://filebin.ca/mcmhj

Problem can be reproduced with mythavtest and actually there's no need to skip in, normal playback into the program is enough.

comment:3 Changed 9 years ago by anonymous

Could this be related with http://svn.mythtv.org/trac/ticket/9215? I saw in your log that you're also outputting with XVideo!

Regards, dargllun

comment:4 Changed 9 years ago by markk

Milestone: unknown0.25
Resolution: Works for me
Status: acceptedclosed

Otto - I'm closing this as the clip appears to work without issue with the latest trunk code. If you are still seeing the issue (or indeed anything related) - please open again or create another ticket. Thanks, Mark

Note: See TracTickets for help on using tickets.