Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#8769 closed defect (Invalid)

White noise or no sound after seeking, when using PULSEAUDIO:default

Reported by: jeremy@… Owned by: JYA
Priority: major Milestone: 0.24
Component: MythTV - Audio Output Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Same symptoms as 0.23's http://svn.mythtv.org/trac/ticket/8237 but observed under 25594

Attachments (2)

mythaudio.log (16.3 KB) - added by brtab at comcast.net 9 years ago.
mythfrontend -v audio
mythfrontend.log (57.9 KB) - added by Matthew Wire <devel@…> 9 years ago.
-v audio log

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by jeremy@…

To quote the other bug:

Consolidating reports from downstream users:

FE configured to use PULSEAUDIO:default

Recorded or Live TV will start out playing correct audio, but seeking ffw or rwd loses proper audio, getting either white noise static (raw digital data?) or no sound at all.

To restore proper audio, one of the following must be done:

  1. Select an alternative audio channel and coming back to the default one
  1. Repeated skipping again or hitting pause will sometimes, eventually, restore audio
  1. If all else fails, get out of play mode and starting play again

comment:2 Changed 9 years ago by robertm

Status: newassigned

comment:3 Changed 9 years ago by robertm

Status: assignedinfoneeded

Need logs with -v audio when this occurs. Also, if you really want this looked at, a much, much better description would be advisable.

Changed 9 years ago by brtab at comcast.net

Attachment: mythaudio.log added

mythfrontend -v audio

Changed 9 years ago by Matthew Wire <devel@…>

Attachment: mythfrontend.log added

-v audio log

comment:4 Changed 9 years ago by Matthew Wire <devel@…>

Been meaning to report this myself but haven't had the time to investigate. The same issue has been happening to me for a while now - I use the ALSA:pulse output as a workaround but this has issues with stuttering and sync so is not a great workaround!

Currently running 25607 on ubuntu 10.04 64bit with pulseaudio configured for simultaneous output to both soundcards.

comment:5 Changed 9 years ago by Matthew Wire <devel@…>

My log uses Pulseaudio:default for the first two times and ALSA:pulse for the final time. White noise was heard for both the first two times.

comment:6 Changed 9 years ago by stuartm

Status: infoneededassigned

comment:7 Changed 9 years ago by stuartm

Milestone: unknown0.24
Version: UnspecifiedTrunk Head

comment:8 Changed 9 years ago by JYA

Resolution: Invalid
Status: assignedclosed

Change the default sampling rate of the pulseaudio server from 44.1kHz to 48kHz or change the default resample algorithm.

The issue is in the pulse server

comment:9 Changed 9 years ago by matthias@…

So why do I see this error regardless of which resampling method I set up in Pulseaudio?

And if it's a pulse issue, could you please link to their bug?

comment:10 in reply to:  8 Changed 9 years ago by anonymous

Replying to jyavenard:

Change the default sampling rate of the pulseaudio server from 44.1kHz to 48kHz or change the default resample algorithm.

This actually solves the issue in 0.24 (at least for me). There is somekind of option for this in Advanced Audio options in Mythtv setup, but haven't tried if it works.

Work-around that I use is to put default-sample-rate = 48000 in /etc/pulse/daemon.conf. I use mythtv 0.24 on Ubuntu 10.10.

comment:11 Changed 7 years ago by pmb@…

anonymous's work-around didn't work for me, but I went into the mythfrontend Audio settings, and in "Advanced Audio Setting" i selected "Override SRC quality" and Sample rate conversion: Disabled.

comment:12 Changed 7 years ago by JYA

Ticket locked: set
Note: See TracTickets for help on using tickets.