Opened 9 years ago

Closed 9 years ago

#8920 closed defect (fixed)

Applie silver remote on Mac OS 10.6 does not work with MythTV

Reported by: anonymous Owned by: Nigel
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

The select and the play button on the silver remote does not seem to work in mythtv on Mac OS 10.6 The arrow and menu buttons work fine.

Change History (5)

comment:1 Changed 9 years ago by anonymous

This was for r25260

comment:2 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed

Dupe of #6422.

comment:3 Changed 9 years ago by Nigel

Milestone: unknown0.24
Priority: majorminor
Resolution: Invalid
Severity: mediumlow
Status: closednew
Version: UnspecifiedTrunk Head

comment:4 Changed 9 years ago by Nigel

Owner: set to Nigel
Status: newassigned

#6422 was a different Apple Remote problem. I don't have one of these remotes (which is a shame becasue it has an extra button), but fix should just be adding a few codes in the cookie mapping, and I think I just found someone else's code that has them!

comment:5 Changed 9 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [26287]) Support newer Aluminium Apple remote, which has an extra button. Closes #8920. Since a new AppleRemote? enum had to be added for appropriate functionality, I took the opportunity to relabel the button codes and document a little.

Note: See TracTickets for help on using tickets.